[PP]windows 9x only: euro character does not display

VERIFIED FIXED in M5

Status

()

Core
Layout
P3
normal
VERIFIED FIXED
19 years ago
12 years ago

People

(Reporter: cpratt, Assigned: Erik van der Poel)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
A simple HTML file with "€" in it doesn't display the euro character; it
displays what I think is the tab character. The same file displays correctly in
4.5x and MSIE 4.x.

Sample HTML:

<html><head></head><body>&euro; is the Euro symbol.</body></html>

Comment 1

19 years ago
Setting all current Open/Normal to M4.

Comment 2

19 years ago
giving all of garret's bugs to don. Don, if you're the wrong person, a thousand
apologies.

Updated

19 years ago
Assignee: don → rickg

Comment 3

19 years ago
Re-assigned to rickg@netscape.com.

Rick, any idea who should get this beast?  Sounds like some kind of layout
problem?

Updated

19 years ago
Component: Windows FE → Layout
Product: MozillaClassic → Browser
Version: 1998-03-31 → other

Comment 4

19 years ago
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser

Updated

19 years ago
Assignee: rickg → ftang

Comment 5

19 years ago
Frank -- The parser see and processes these correctly. It appears to be a font
rendering problem. Perhaps you'd like to fix this?

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 6

19 years ago
petersen, could you verify again about this bug. I cannot reproduce this in my
system. It is possible a fix I check in in Layout last week fix this problem.
The fix I check in is to fix the case a non-ASCII only in the position of the
beginning of a *word*. Before my fix, a word which have non-ASCII in the first
character and first character only won't display that character correctly. The
euro sign along is one of the case. (NOTE: The problem is in nsTextTransfomer,
mHasMultiByte does not get turn TRUE when only the first character of the word
is non-ASCII)

I will mark this fix since I cannot reproduce this in 3-15 build on Window 98.
Please verify and reopen it if you can reproduce this on window 98 w/ a version
later than 3/15. Thanks.

Add teruko@netscape.com (IQA) to the cc list.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

19 years ago
Looks good to me on Mac OS 8.5, Win NT, Win 98. March 16 build.

Comment 8

19 years ago
According to Chris Pratt, updating Win NT with service pack 4 will resolve the
Euro character problem. Windows 98 and 95 have simular solutions.
(Reporter)

Comment 9

19 years ago
Originally, this problem was reported against NT 4 SP 4 and Windows 98, but it
was fixed at some point.

If anyone else needs to regress this bug, note that whether or not you'll have
the Euro character available for seamonkey depends entirely on your OS. Clean
installs of Mac OS 8.5 work. NT 4 Service Pack 4 works. Windows 98 should work.
Other OSes will need vendor-supplied patches or updates to work correctly with
the euro character.
(Reporter)

Updated

19 years ago
Status: VERIFIED → REOPENED
(Reporter)

Comment 10

19 years ago
It's broken in apprunner, the april 9 build.
(Assignee)

Updated

19 years ago
Resolution: FIXED → ---
(Assignee)

Updated

19 years ago
Assignee: ftang → erik
Status: REOPENED → NEW
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M4 → M5
(Assignee)

Updated

19 years ago
Summary: Euro character does not display → Windows: euro character does not display
(Assignee)

Comment 11

19 years ago
Let's make this the Windows euro bug report. If there are problems with the
euro on other platforms (Mac, Linux) please create separate bug reports.
(Reporter)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
Summary: Windows: euro character does not display → windows: euro character does not display
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 12

19 years ago
it seems to be working correctly on the mac and under windows nt using the april
12 and 13 builds. marking as fixed and verifying. we should however check the m4
build again to make sure it's fixed in that build (i only verified it against
early m5 builds).
(Reporter)

Updated

19 years ago
Status: VERIFIED → REOPENED
Summary: windows: euro character does not display → [PP]windows 9x only: euro character does not display
(Reporter)

Updated

19 years ago
Resolution: FIXED → ---
(Reporter)

Comment 13

19 years ago
sorry, this is broken on windows 98 and 95 but works every else.
(Reporter)

Comment 14

19 years ago
sorry, meant to say 'everywhere else' (works on nt 4 sp 4 and mac os 8.5.1).
(Assignee)

Updated

19 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → FIXED

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 15

18 years ago
Fixed in April 26th Win 32 Build.
You need to log in before you can comment on or make changes to this bug.