cannot access the windows taskbar in full screen mode (auto hidden)

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
14 years ago
5 years ago

People

(Reporter: Antonio, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

also when i hit f11 the browser produces another bottom bar, "that displays
"done," for a total of two bars at the bottom, and of course no autohidden
taskbar.  

Reproducible: Always
Steps to Reproduce:
1.open firefox, with windows xp taskbar set to autohide
2.press f11
3.press f11 again

Actual Results:  
Two of what are supposed to be the bottom of the page frame appear.

Expected Results:  
gone back and forth between full screen and non full screen with ease, and all
the while able to access the autohidden taskbar.

Comment 1

14 years ago
Does it only happen when you use F11 to toggle the mode? What if you use the
mouse to do it?
Summary: when using full screen mode i cannot call up the autohidden windows taskbar → when using full screen mode i cannot call up the autohidden windows taskbar

Comment 2

14 years ago
(In reply to comment #1)
> Does it only happen when you use F11 to toggle the mode? What if you use the
> mouse to do it?

No, this also occurs when using the menu (View->Full Screen) to toggle full
screen mode.  (you can get out of the full-screen mode with the keyboard as
well, by hitting Alt-V, then navigating to the Full Screen option in the menu.)

I can reproduce this bug with tonight's FB nightly, on Windows XP.  Mozilla/5.0
(Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040727 Firefox/0.9.1+

When the buggy behavior occurs (Firebird doesn't seem to repaint the area
occupied by the Windows taskbar area when it minimizes), the Title bar at the
top of the page (including the minimize/maximize/close buttons), and the left
and right windows chrome, appear to be missing as well.

The workaround, when the bug occurs, seems to be to maximize another window on
top of Firefbird, and then switch back to Firebird.

Comment 3

14 years ago
Dup of bug 127160?

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

14 years ago
The taskbar should be auto-hide(/show) when in full-screen mode, regardless of
whether or not the taskbar setting was show or auto-hide. Right now, we just
hide it and that's wrong on Windows. We should auto-hide it.

Comment 5

14 years ago
(In reply to comment #4)
> The taskbar should be auto-hide(/show) when in full-screen mode, regardless of
> whether or not the taskbar setting was show or auto-hide. Right now, we just
> hide it and that's wrong on Windows. We should auto-hide it.

Asa, the comment is good, but I believe this bug is a dupe of bug 127160 as
suggested by Jesse in comment #3. (I'd dupe it but I don't have the privs.)

I suggest duping to bug 127160

Comment 6

14 years ago
Not accessibility specific -- affects everyone.
Assignee: aaronleventhal → firefox
Component: Accessibility → General
QA Contact: bugzilla → firefox.general
*** Bug 283483 has been marked as a duplicate of this bug. ***
Assignee: firefox → nobody
Severity: major → normal
Depends on: 127160
I'm not sure if setting Auto-Hide temporarily is possible. Even if it were, I think we'd need to make full screen not-quite fullscreen to have a hoverable pixel near the bottom.
Summary: when using full screen mode i cannot call up the autohidden windows taskbar → cannot access the windows taskbar in full screen mode (auto hidden)

Updated

11 years ago
Duplicate of this bug: 401037
Duplicate of this bug: 501865
With Windows XP, I am no longer able to reproduce the bug using the STR in comment 0.

Please re-open if this is still an issue.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.