Browser crashes upon trying to login to citibank online/alerting service

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Timofey Vorobyov, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.8a1) Gecko/20040521 via Smart Cache 0.65
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.8a1) Gecko/20040521 via Smart Cache 0.65

The browser crashes when I try to open Citibank Online or Alerting service windows

Reproducible: Always
Steps to Reproduce:
1.Go to the url specified above
2.click English (the site is in Russian, russian version crashes as well)
3.Click "Citibank Online" or "Alerting Service" links

Actual Results:  
A new browser window appears, then in a few seconds the browser crashes

Expected Results:  
Normal operation with the online service

(no sub-component identified)

07-20-2004  11:30:21  SYS3175  PID 2f74  TID 0002  Slot 00ca
G:\TCPIP\MOZ18\MOZILLA.EXE
c0000005
00000000
P1=00000001  P2=00000000  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=0159f020  EBX=00000000  ECX=00000002  EDX=00680144
ESI=00000000  EDI=00000000  
DS=0053  DSACC=d0f3  DSLIM=3fffffff  
ES=0053  ESACC=d0f3  ESLIM=3fffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:00000000  CSACC=d0df  CSLIM=3fffffff
SS:ESP=0053:04abf84c  SSACC=d0f3  SSLIM=3fffffff
EBP=00000000  FLG=00012202
(Reporter)

Comment 1

14 years ago
Works fine in 1.4
Worksforme with a current Linux trunk build....

Updated

14 years ago
Keywords: crash

Comment 3

14 years ago
This doesn't happen with 1.8a2 which I just uploaded.

Comment 4

14 years ago
Works for me.  Linux 1.8a3 (CVS)
(Reporter)

Comment 5

14 years ago
(In reply to comment #3)
> This doesn't happen with 1.8a2 which I just uploaded.

Works for me with 1.7 (latest stable version I have). Will try 1.8a2 tomorrow
(Reporter)

Comment 6

14 years ago
Still does not work with 1.8a2
==============================

07-21-2004  15:03:53  SYS3175  PID 4512  TID 0002  Slot 0089
G:\TCPIP\MOZ18A2\MOZILLA.EXE
c0000005
00000000
P1=00000001  P2=00000000  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=00b98e40  EBX=00000000  ECX=00000002  EDX=00680144
ESI=00000000  EDI=00000000  
DS=0053  DSACC=d0f3  DSLIM=3fffffff  
ES=0053  ESACC=d0f3  ESLIM=3fffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:00000000  CSACC=d0df  CSLIM=3fffffff
SS:ESP=0053:04abf84c  SSACC=d0f3  SSLIM=3fffffff
EBP=00000000  FLG=00012202

Comment 7

14 years ago
that crash looks like a wrong level of security is being loaded since there is a
null CS:EIP.

Can you create a new profile for testing purposes and try it?
(Reporter)

Comment 8

14 years ago
(In reply to comment #7)
> that crash looks like a wrong level of security is being loaded since there is a
> null CS:EIP.
> 
> Can you create a new profile for testing purposes and try it?


Works with a blank profile (shows login screen).

Comment 9

14 years ago
So it would appear that there is a problem loading the security databases.

Can you try renaming cert.db to cert.bak in the failing profile and see if that
fixes it?
(Reporter)

Comment 10

14 years ago
(In reply to comment #9)
> So it would appear that there is a problem loading the security databases.
> 
> Can you try renaming cert.db to cert.bak in the failing profile and see if that
> fixes it?

Renamed cert8.db to cert8.bak. Browser still crashes with the following details:

07-22-2004  16:35:04  SYS3175  PID 5475  TID 0002  Slot 00d5
G:\TCPIP\MOZ18A2\MOZILLA.EXE
c0000005
00000000
P1=00000001  P2=00000000  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=00c29700  EBX=00000000  ECX=00000002  EDX=00680144
ESI=00000000  EDI=00000000  
DS=0053  DSACC=d0f3  DSLIM=3fffffff  
ES=0053  ESACC=d0f3  ESLIM=3fffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:00000000  CSACC=d0df  CSLIM=3fffffff
SS:ESP=0053:04abf84c  SSACC=d0f3  SSLIM=3fffffff
EBP=00000000  FLG=00012202

Comment 11

14 years ago
You should try renaming files one  at a time in the profile to see if you can
find the one that is causing the problem.

Comment 12

13 years ago
have you been able to try this?

Comment 13

13 years ago
This is WFM. Sorry. There was a conflict between two security levels.

I got the name of the file to rename wrong - secmod.db.

This should fix the problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.