If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Site defeats 'always show context menu' preference

RESOLVED DUPLICATE of bug 326543

Status

()

Firefox
Menus
RESOLVED DUPLICATE of bug 326543
13 years ago
5 years ago

People

(Reporter: uamjet602, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9

Thanks to bug 86193, there is a preference for preventing the annoying habit of
bad 'web designers' to mess with the context menu.

Unfortunately this site manages to do that even with the preference enabled
('Allow to' is off, just to be clear). I'm getting close to asking for a pref to
disable -all- javascript alerts, it's been years since I saw a useful one.

Reproducible: Always
Steps to Reproduce:
1. Go to Edit/Preferences/Web Features and click on the Advanced button next to
Java/Javascript. Disable the checkbox for 'Disable or replace context menus'
2. Go to the url
3. rightclick on the page

Actual Results:  
A javascript popup 'Right Click has been disabled'

Expected Results:  
no javascript popup; context menu should show up.

I am using the optimoz gestures extension; I can imagine that interfering. I
changed it from using the right mouse button to the left one but it did not make
a difference.

I know there's bug 86193, but I don't want all the 'web developer' vs 'user'
discussion again. Besides, that bug is way too long already, and it's for
mozilla, not firefox.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040719
Firefox/0.9.1+

rightclick brings up the (alert) popup .... and the context menu at the same time.
The Contextmenu works.

Comment 2

13 years ago
I get same as comment 1 in 1.7 on OS/2, except that after dismissing the
alert/menu, the alert redisplays one time.

Comment 3

13 years ago
I have this issue with Firefox 1.0.1 with no extensions.  New browser windows
are launched by some web pages with no context menus even though "Disable or
replace context menus" is clear (unchecked).

Example http://www.wjr.com  - "click here to listen"

Updated

12 years ago
Assignee: firefox → nobody
QA Contact: bugzilla → menus

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 326543
You need to log in before you can comment on or make changes to this bug.