Flash objects embeded in HTML pages do not refresh when scrolling.

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: sevendusk, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9

This site (http://www.abrasivemedia.org/kosovoa) is entirely in Flash and is set
to fill 100% of the width and height of the page without scaling.  This site
uses a 1px jpeg to dynamicly change the amount of scrollable space in the HTML.
 However, Firefox does not reverl any scrollable content unless you reseize the
window. Click the Links button on the site to see what I mean.

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.abrasivemedia.org/kosovoa
2. Click the Links button.
3. Scroll down .... its all blank (you should see content here).

Actual Results:  
When you scroll down, anything below the bottom of the window does not appear.

Expected Results:  
The content should be viewable.  Check the site in Internet Explorer, you'll see.

The images is resized with javascript.  This resize method is compliant with
Mozilla.  So I'm left to believe this issue may have to deal with Firefox's
handeling of ActiveX elements such as Flash.

Comment 1

14 years ago
Confirmed. Good catch Justin!

Comment 2

14 years ago
Also happens in Mac OS; all Flash elements 'disappear' when I scroll a page or
resize the window. Right-clicking and choosing "Zoom in" then "Show all" from
the Flash context menu forces a redraw, but this often has to be done after
every interaction with a site's Flash interface. Happens on every site with
Flash elements.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913
Firefox/0.10 StumbleUpon/1.998
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 4

13 years ago
Bug still present for me. All Flash elements disappear on scrolling or clicking,
and you have to use the Flash contextual menu to get parts to reappear. Makes
Flash-interface sites unusable in Firefox.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.8) Gecko/20050511
Firefox/1.0.4

Comment 5

13 years ago
Works for me in Firefox 1.5 beta 2
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051013
Firefox/1.4.1

Comment 6

13 years ago
Works for me (Firefox 1.5.0.1 ID:2006011112, WinXP, Shockwave Flash 8.0 r22).

Justine, Elaine - your reported Firefox versions are too old a build to analyze bugs against now. The problem you are reporting may well have been fixed already. 

Could you please download a recent version or nightly build from <http://www.mozilla.org/releases/nightly.html>, and then let us know if you still see this problem?

Many thanks, Cigno

Comment 7

12 years ago
Since there has been no reply to comment #6 and the WFMs in comment 5 & 6 ==> WORKSFORME. 

The reported Firefox version(s) are too old a build to analyze bugs against now. The problem you are reporting may well have been fixed already.

Could you please download a recent version or nightly build from <http://www.mozilla.org/releases/nightly.html>, and then let us know if you still see this problem? If so feel free to report back and ask for the bug to be reopened.

Many thanks, Cigno
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.