Make extensions droppable in extensions/

RESOLVED DUPLICATE of bug 286034

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 286034
15 years ago
11 years ago

People

(Reporter: doronr, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
I should be able to drop an .xpi inside of extensions/ and have it installed
when ff starts the next time.

This would be usefull for big deployments of ff.  Shellblock.xpi could be
deployed like this to a whole company, as many use their own installation
mechanisms.
(Reporter)

Comment 1

15 years ago
Got cut off:

Currently, you can drop xpcom components into compontents/ and touch an .autoreg
file to get the components registered on next startup.
Would this be a global installation or just per-profile?  In a controlled
environment, the user probably won't have write access to the install directory,
or at least we can't assume they'll have it.  We could always try global and
fall back to profile-only if necessary.
(Reporter)

Comment 3

15 years ago
since firefox is aiming at single profileness, it should probably be per profile.

Comment 4

15 years ago
well at least this method can help in other ways
you talk about one user

then here this
dial-up users at least can breath fresh air
they could download their extensions and back them on any medium the prefer
and if they update or format their hard drives they don't have to go online
to get the extensions but instead they can install it
(Reporter)

Comment 5

15 years ago
dial-up people can download the xpi, then open it in Mozilla.  This is more
usefull for larger deployments.

Comment 6

15 years ago
This should be better documented, and locally so, too. In Mozilla (old style), I
can usually choose whether to install an extension per-user (as the running
user), or globally if I'm running as root. I didn't see this in Firefox, and it
installed the extensions locally in root's profile. Instead, it should either
ask, or the extensions mechanism should be done in a way that the extensions/
portion of the profile could be easily copied around to other profiles, or the
global profile, at least after some easy-to-do and documented tweaking of some
text strings (eg. paths).

I also noted that Firefox records absolute paths in some of the extensions
uninstall area at least which would break badly if the profile would be moved
around itself (eg. due to migration to a different file system layout).

Comment 7

14 years ago
*** Bug 251946 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Severity: normal → enhancement

Comment 8

14 years ago
*** Bug 271672 has been marked as a duplicate of this bug. ***

Comment 9

14 years ago
will bug 286034 give you this?
(Reporter)

Comment 10

14 years ago
Not exactly the same, but it is up to ben to decide.

Comment 11

13 years ago
What we did is done...

*** This bug has been marked as a duplicate of 286034 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.