Inline frame in a table does not display default background color

RESOLVED DUPLICATE of bug 154957

Status

()

defect
RESOLVED DUPLICATE of bug 154957
15 years ago
5 years ago

People

(Reporter: chuckbeyea, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

Have an i-frame in a table - in IE, background of frame is white (probably the
default setting). In Firefox, background of frame is same as background of cell
the frame is embedded in. Can be seen at www.basketball.nb.ca - but - 
Have stripped code down as much as possible to re-create the problem.
HTML is included below.
html>
   <body>
      <table>
         <tr>
            <td bgcolor="#cc0000">
               <iframe name="I-Frame" width="75%" >
               </iframe>
            </td>
         </tr>
      </table>
   </body>
</html>

PS - apologies if this is a previously identified issue. Excellent product -
keep up the good work.

Chuck
chuckbeyea@hotmail.com

Reproducible: Always
Steps to Reproduce:
1.open included HTMl in Firefox and in IE - difference is obvious
2.
3.

Actual Results:  
Different colors are displayed depending on the client (either ID or FireFox)

Expected Results:  
Expected same display -

Updated

15 years ago
Assignee: bugs → nobody
Component: Tabbed Browser → Layout
Product: Firefox → Browser
QA Contact: firefox.tabbed-browser → core.layout
Version: unspecified → Trunk
it inherits the background-color from the body above it.
btw <td bgcolor="#cc0000"> should be <td style="background-color:#cc0000">
iframes inherit background.  This is quite purposeful.
Whiteboard: DUPEME

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 154957 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.