Closed Bug 252361 Opened 17 years ago Closed 8 years ago

Easy rebranding

Categories

(Firefox :: General, defect)

defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: BenB, Unassigned)

References

Details

(Per bz) There should be a build switch to change the appname from "Firefox" to
something else, replacing *all* user-visible and user-relevant instances of the
name, including artwork, UI, filename, installer, maybe profile, maybe mechanics
(DDE etc.).

To be changed (not complete):
- There is already a switch to change the profile location, but IIRC it didn't
work (in all cases?).
- other-licenses/branding/firefox/
- other places with artwork?
- installer has the name hardcoded all over the config files
- xremote, DDE etc.
- brand.dtd, brand.properties, region.properties
- makefiles (filename)
- Windows resources: /browser/app/module.ver, /browser/app/splash.rc,
  /browser/app/firefox.exe.manifest
- Profile migration
- help (all over)
- /browser/components/shell/src/nsWindowsShellService.cpp, line 185 -- #define
EXE "firefox.exe"
- /toolkit/mozapps/update/src/update.rdf?
- credits, about (mac .info, html/xul files)
- README
- /browser/components/help/locale/en-US/cookies.xhtml
- default bookmarks
- /browser/locales/en-US/chrome/browser/pref/pref-extensions.dtd, line 11 --
<!ENTITY getnew.tooltip "Close Options and visit Firefox Help's Extensions
page">, same for themes,
/toolkit/locales/en-US/chrome/mozapps/extensions/extensions.properties
Why?
Firefox can already be rebranded very easily.

Either way this should be an enhancement.
> Why?

Because Mozilla was supposed to be a toolkit for 3rd parties, and many companies
are doing that, and need to change the branding. Thus not enhancement, but
requirement.

> Firefox can already be rebranded very easily.

Obviously not, as shown above.
-> enhancement

Anyway I think the reporter should submit each point in To Be Changed List as a
 separate bug after withdrawing this bug. In that way they'll be processed more
quickly than this bug.
Severity: major → enhancement
No, this list is not complete and will need to be a coordinated effort, if
nothing else so that reviewers see the context.

> -> enhancement

See comment 2 (esp. given MoFo's trademark policy)
Severity: enhancement → major
(In reply to comment #4)
> See comment 2 (esp. given MoFo's trademark policy)

Then why not change Product from Firefox to Mozilla Application Suite? Unless
you change it into Mozilla Application Suite, Severity: Major doesn't make
sense, IMHO. Firefox is a branding effort.
> Then why not change Product from Firefox to Mozilla Application Suite?

Because the list in comment 0 is the list of things needed to de-brand _Firefox_.

> Firefox is a branding effort.

Firefox is not just a branding effort, I hope.  If it is, just prohibit people
from making non-Mozilla-Foundation builds from the code altogether, and be done
with it instead of just making it hard to make non-branded versions...
The toolkit is supposed to be a toolkit for third parties, Firefox is not. There
are already several bugs about using the --enable-branding and
--enable-official-branding flags to consolidate the trademarked elements of the
source.

The only real bug here is
/toolkit/locales/en-US/chrome/mozapps/extensions/extensions.properties and I
hope to take care of that soon, with the EM rewrite.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → INVALID
(In reply to comment #6)
> > Then why not change Product from Firefox to Mozilla Application Suite?
> 
> Because the list in comment 0 is the list of things needed to de-brand _Firefox_.

OK I made a stupid commment, the list is indeed about the FireFox code.
Ben tries to make Firefox more Mozilla-like, probably related to Bug 54184.
Anyway my point is this bug should not be classified as 'major', or valid.
bz points out that this bug is not invalid, it's a dup...
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
dupe of Bug 286149?

*** This bug has been marked as a duplicate of 269460 ***
Status: REOPENED → RESOLVED
Closed: 16 years ago16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
bsemdberg wrote in bug 269460 comment 24:
> This bug (i.e. the ability to select a branding directory at configure time) is
> checked in on trunk for 1.8b4. Actually putting all the references to "firefox"
> into this directory is going to take more work, in bug 252361 or elsewhere.

So, reopening this one. See initial description.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
Depends on: 356578
I looked into names a bit, and here's a brief summary and my proposals.

http://wiki.mozilla.org/User:Torisugari

bug 362902 is targeting Fx2.0, but the issue such as
bug 362902#c3 is very interesting as a trunk bug as well,
especially Torpark problem.

> There are some screenshots of the torpark case at
> http://people.mozilla.com/~chofmann/torpark/
Torisugari, thanks for the summary.

There is a fine line between what should change and what not, though. Speaking from experience as Mozilla redistributor: I like it when we can change the display name anywhere. I think it's very bad to change *technical* things which may break usage of a browser as Firefox replacement, though.

Esp. DDE name and xremote is critical, as said in bug 356578, these *must* work cross-browser.

The profile is a tough one, an alternative browser may or may not want to use a different profile. Ideally, all Mozilla browser should use the same profile, because it's user-data and he'll want to have the same set of pres when switching back and forth between alternative browsers, e.g. when trying things out - a different profile is a real bummer. Unfortunately, Mozilla keeps all kinds of crap in the user profile which is not user data, like the component registry and extensions, which can really hose things. It's an annoyance even when switching between my distro's FF 1.5.x and my own FF 2.0.x. The decision whether to use a different profile or not is thus a touch one and needs to be very explicit by the distributor, he may want one or the other. (And FF should and already does protect itself technically when using the profile.) So, I do not think that should be tied directly with the app name change, by default it should use the FF profile, because probably most users and thus distributors expect their bookmarks, passwords etc. to stay the same.
To clarify: It's good to have a switch to be able to change xremote/DDE name (assuming they do the same, in effect) and profile. It should not be tied with the main branding switch, though, but be separate, given the consequences for app usage.
Assignee: bross2 → nobody
Status: REOPENED → NEW
I think Firefox can now be easily re-branded (see, for example, IceWeasel)...

Is this still an issue, BenB?
Flags: needinfo?(ben.bucksch)
I haven't checked, but given IceWeasel, I assume so.
FIXED by unknown person.
Status: NEW → RESOLVED
Closed: 16 years ago8 years ago
Flags: needinfo?(ben.bucksch)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.