If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Update Linkification extension

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED FIXED
13 years ago
2 years ago

People

(Reporter: John Hansen, Assigned: alanjstr)

Tracking

Details

(Whiteboard: In queue)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

I have written an extension for Firefox versions 0.9 and up, and would like to
submit it to be posted at update.mozilla.org

I am new to the extension submittal process, so I have no idea how to upload the
xpi file.  Please contact me whenever possible..  Thanks!!

-John

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

13 years ago
Created attachment 153848 [details]
This extension encloses all text URLs within anchor tags.

Linkification works for Firefox versions 0.9 and up.

-John
(Assignee)

Comment 2

13 years ago
Please post the URL where your file can be downloaded.
Assignee: psychoticwolf → Bugzilla-alanjstrBugs
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

13 years ago
Alan,

I don't currently have a website.  Is it a requirement to have a download site?
 If so, I can set one up..
(Assignee)

Comment 4

13 years ago
We don't accept bugzilla attachments.  We're weird like that.
Status: NEW → ASSIGNED
Summary: Linkification (Firefox 0.9+ Extension submission) → Add Linkification extension
(Reporter)

Comment 5

13 years ago
http://www.beggarchooser.com/firefox/linkification_0.7.8.xpi
(Reporter)

Comment 6

13 years ago
You can download it from:
http://www.beggarchooser.com/firefox/
(Assignee)

Updated

13 years ago
Whiteboard: In queue
(Reporter)

Comment 7

13 years ago
i just have one more question:

when this is posted on update.mozilla.org, which version will be posted?  the
one i've attached to this bug, or the most recent revision on my URL?  i'd
prefer it to be the most recent.

sorry, like i said, this is my first extension.

thanks!
(Assignee)

Comment 8

13 years ago
	Linkification 0.7.8
(Reporter)

Comment 9

13 years ago
if possible, please use this instead:

http://www.beggarchooser.com/firefox/linkification_0.8.2.xpi

if not, it's completely understood..  thanks for your help!
(Assignee)

Comment 10

13 years ago
Done.
(Assignee)

Comment 11

13 years ago
Making its way to the mirrors.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Hardware: PC → All
Resolution: --- → FIXED
(Reporter)

Comment 12

13 years ago
this should be the final update to the linkification extension for a while:

http://www.beggarchooser.com/firefox/linkification_0.8.3.xpi

how frequently am i expected/allowed to post updates to an extension?  i have
been in a serious programming frenzy lately and keep expecting the current
version to be the last.  but i don't want to be a cause of frustration.

thanks again..
(Reporter)

Comment 13

13 years ago
also, for the "Profile for John Hansen"

my homepage is http://www.beggarchooser.com/firefox/
and my e-mail address is yellow5@beggarchooser.com

Comment 14

13 years ago
(In reply to comment #12)
> how frequently am i expected/allowed to post updates to an extension?  

You can post an update as often or as seldom as you like. There's just no
guarantee that an editor will get to it before another one comes along.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 15

13 years ago
yet another update..

http://www.beggarchooser.com/firefox/linkification_0.8.4.xpi
(Assignee)

Updated

13 years ago
Status: REOPENED → ASSIGNED
Whiteboard: In queue
(Assignee)

Updated

13 years ago
Whiteboard: In queue
(Reporter)

Comment 16

13 years ago
http://www.beggarchooser.com/firefox/linkification_0.8.5.xpi
(Assignee)

Updated

13 years ago
Whiteboard: In queue
(Assignee)

Updated

13 years ago
Whiteboard: In queue

Comment 17

13 years ago
0.8.5 in Queue.
Just so you know, your max version in the install.rdf is currectly 0.9.
While this should be 0.9.2 as that is the latest Firefox version, and your
extensions works in it.

Just so you know for the next version.
(Reporter)

Comment 18

13 years ago
http://www.beggarchooser.com/firefox/linkification_0.8.6.xpi
(Assignee)

Comment 19

13 years ago
Files are making their way to the mirrors.  Please reopen this bug if you have
an update to your theme/extension.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 20

13 years ago
http://www.beggarchooser.com/firefox/linkification_0.9.0.xpi
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

13 years ago
Status: REOPENED → ASSIGNED
Whiteboard: In queue
(Assignee)

Updated

13 years ago
Whiteboard: In queue
(Reporter)

Comment 21

13 years ago
http://www.beggarchooser.com/firefox/linkification_0.9.1.xpi
(Assignee)

Updated

13 years ago
Whiteboard: In queue
(Assignee)

Updated

13 years ago
Summary: Add Linkification extension → Update Linkification extension
Whiteboard: In queue
(Assignee)

Updated

13 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
Whiteboard: In queue
(Reporter)

Comment 22

13 years ago
http://www.beggarchooser.com/firefox/linkification_0.9.2.xpi
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

13 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Updated

13 years ago
Whiteboard: In queue
(Reporter)

Comment 23

13 years ago
http://www.beggarchooser.com/firefox/linkification_0.9.3.xpi
(Assignee)

Comment 24

13 years ago
Please reopen this bug if you have an update.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
(Assignee)

Updated

13 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: In queue
(Reporter)

Comment 25

13 years ago
http://www.beggarchooser.com/firefox/linkification_0.9.4.xpi
(Assignee)

Updated

13 years ago
Status: REOPENED → ASSIGNED
Whiteboard: In queue
(Reporter)

Comment 26

13 years ago
http://www.beggarchooser.com/firefox/linkification_0.9.5.xpi

It didn't give me the choice to reopen, so I reassigned it..  Is this correct,
and if not, how should I have reopened it?
Status: ASSIGNED → NEW
(Assignee)

Updated

13 years ago
Assignee: Bugzilla-alanjstrBugs → cst
(Reporter)

Comment 27

13 years ago
http://www.beggarchooser.com/firefox/linkification_0.9.6.xpi
Wolf, I can't figure out how to update an extension.  I get the impression
something in the admin area is broken.  ->you.  Reassign to me once I understand
how to do it (if you haven't already resolved this by then).
Assignee: cst → psychoticwolf

Comment 29

13 years ago
(In reply to comment #26)
> It didn't give me the choice to reopen, so I reassigned it..  Is this correct,
> and if not, how should I have reopened it?

The bug wasn't resolved, so you couldn't reopen. It wasn't closed yet. 

Linkification 0.9.6 has been added and approved. Give time for the mirrors to
catch up. :-)
Status: NEW → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
Whiteboard: In queue
(Reporter)

Comment 30

13 years ago
http://www.beggarchooser.com/firefox/linkification_0.9.7.xpi

sorry about being so trigger happy; i'll be more patient =)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

13 years ago
Assignee: psychoticwolf → cst
Status: REOPENED → NEW
Status: NEW → ASSIGNED
Whiteboard: in queue
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
Whiteboard: in queue
(Reporter)

Comment 31

13 years ago
http://www.beggarchooser.com/firefox/linkification_0.9.10.xpi
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → ASSIGNED
Whiteboard: in queue
(Assignee)

Updated

13 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
Whiteboard: in queue
(Reporter)

Comment 32

13 years ago
http://www.beggarchooser.com/firefox/linkification_0.9.14.xpi
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → ASSIGNED
Whiteboard: in queue
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
Whiteboard: in queue
(Reporter)

Comment 33

13 years ago
http://www.beggarchooser.com/firefox/linkification_0.9.18.xpi
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: in queue, active
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
Whiteboard: in queue, active → active
Whiteboard: active
(Reporter)

Comment 34

13 years ago
For some reason, Linkification 0.9.7 is now displayed on the update.mozilla.org
site, but the most recent 0.9.18 is no longer anywhere to be found.  Could this
be re-updated please?

Thanks for your time and hard work,
-John
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee: cst → psychoticwolf
Status: REOPENED → NEW

Updated

13 years ago
Assignee: psychoticwolf → jedsbugs
(Assignee)

Comment 35

13 years ago
Taking bugs cause Jed is busy
Assignee: jedsbugs → Bugzilla-alanjstrBugs
(Assignee)

Comment 36

13 years ago
Reassigning to default component owner because this is a php problem and no one
else has access.
Assignee: Bugzilla-alanjstrBugs → psychoticwolf
Whiteboard: In queue

Comment 37

13 years ago
This was not a PHP problem, it was a DB problem. :-)

Fixed.
Whiteboard: In queue

Comment 38

13 years ago
This was not a PHP problem, it was a DB problem. :-)

Fixed.
Status: NEW → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 39

13 years ago
http://www.beggarchooser.com/firefox/linkification_0.9.19.xpi
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

13 years ago
Assignee: psychoticwolf → jedsbugs
Status: REOPENED → NEW
(Assignee)

Updated

13 years ago
Assignee: jedsbugs → Bugzilla-alanjstrBugs
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
Whiteboard: In queue

Comment 40

13 years ago
Bulk Moving Extension/Theme listing bugs to new component.
(Filter: masslistingspam)
Component: Update → Listings
Product: mozilla.org → Update
Version: other → unspecified
(Assignee)

Updated

13 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
AMO BUGSPAM FOR COMPONENT MOVE AND DELETE (FILTER ME)
Component: Listings → Web Site
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.