Closed Bug 252392 Opened 16 years ago Closed 16 years ago

the CSS files linked via the @import keyword are not saved

Categories

(Firefox :: File Handling, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 126309

People

(Reporter: tony.castley, Assigned: bugs)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

Two issues here really, but related.  It appears that Firefox ignores files used
or imported by CSS files.  The url() contents are not inspected, files
downloaded and the url rewritten.

csszengarden shows that as the whole CSS is not downloaded as thier mechanism
(and most others) use the @import within an inline css block.

http://www.castley.net/brog give another example where the CSS is loaded via the
 <link /> tag.  In this case the CSS file is downloaded, however the images used
by the CSS are not.  

Both of these cases are due to not processing the url() elements in the CSS and
both produce less than perfect results for the person saving the site.

Reproducible: Always
Steps to Reproduce:
1. Open http://www.csszengarden.com/
2. File/Save As
3. File/Open file  <filename>
4. Result is a site with NO styling.

Actual Results:  
Result is a site with NO styling.

Expected Results:  
The site should have been rendered off the disk exactly as it was from the site.

*** This bug has been marked as a duplicate of 126309 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.