find toolbar causes multiple notifications of typos

RESOLVED FIXED

Status

()

Toolkit
Find Toolbar
RESOLVED FIXED
14 years ago
10 years ago

People

(Reporter: Nile, Assigned: Blake Ross)

Tracking

unspecified
x86
All
Points:
---
Bug Flags:
blocking-aviary1.0PR -
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

Hard to describe, but here goes. When you start a find for a phrase, for every
character typed incorrectly, the PC speaker will beep. For example, if there is
the phrase "Zarro Boogs" on a page and I quickly type out "/zarroboogs," I will
hear 5 beeps, starting with the b. Also, I will hear a beep each time I hit
backspace to correct my error. Not a huge issue, but it is kind of annoying.

Reproducible: Always
Steps to Reproduce:
1. Type a typo when searching
2. 
3.

Actual Results:  
You hear a beep for each incorrect character, and a beep each time you hit
backspace.

Expected Results:  
Hear a single beep.

Comment 1

14 years ago
Confirming, this behavior is definitely annoying and I can't find a dupe.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All

Comment 2

14 years ago
Created attachment 154863 [details] [diff] [review]
patch to fix

This patch solves the problem.

The "not found" sound will only sound when the first not found character in a
string is typed.  Basically, the sound will only be heard when the "not found"
indication is first displayed.

Comment 3

14 years ago
Comment on attachment 154863 [details] [diff] [review]
patch to fix

requesting review
Attachment #154863 - Flags: review?(firefox)

Comment 4

14 years ago
requesting blocking-aviary1.0PR since patch exists
Flags: blocking-aviary1.0PR?

Updated

14 years ago
Whiteboard: [have patch]
(Assignee)

Comment 5

14 years ago
I'm not sure of the best behavior here. At the very least, we definitely don't
ever want to play a sound on backspace.
Flags: blocking-aviary1.0PR?
Flags: blocking-aviary1.0PR-
Flags: blocking-aviary1.0+
Whiteboard: [have patch]
(Reporter)

Comment 6

14 years ago
(In reply to comment #5)
> I'm not sure of the best behavior here. At the very least, we definitely don't
> ever want to play a sound on backspace.

I suggest to possibly limit the beeping to just two beeps. For example, if I
type "esabishl" when the link is "establish," have Firefox beep for the first
two typos, and not for the rest. Either that, or just limit it to one beep,
which is what the current release does.
(Assignee)

Comment 7

14 years ago
Talking this over with Asa, we believe the current behavior is actually ideal.
We understand the problem that people may take a word really quickly and get a
bunch of beeps. However, we think that's actually okay--we want people to learn
to stop typing as soon as the word isn't found, since that's the main timesaving
benefit of this feature.

Mike, could you produce a patch that leaves the current behavior but doesn't
beep when you backspace or otherwise delete off the end of the word?
(Assignee)

Updated

14 years ago
Attachment #154863 - Flags: review?(firefox) → review-

Comment 8

14 years ago
Created attachment 156713 [details] [diff] [review]
patch for no "not found" sound with backspace or delete

This patch allows the "not found" sound to be heard with every character typed
in a not found string, but does not sound when using backspace or delete to
shorten the string.
Attachment #154863 - Attachment is obsolete: true

Updated

14 years ago
Attachment #156713 - Flags: review?(firefox)

Comment 9

14 years ago
*** Bug 261138 has been marked as a duplicate of this bug. ***
Flags: blocking-aviary1.0+ → blocking-aviary1.0-

Updated

14 years ago
Attachment #156713 - Flags: review?(firefox) → review?(bugs)
(Assignee)

Comment 10

14 years ago
Fix checked in with one minor change. Thanks, Mike!
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

14 years ago
Attachment #156713 - Flags: review?(bugs)
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.