layout messed up when float block is left of table

RESOLVED INVALID

Status

()

Core
Layout: Tables
RESOLVED INVALID
14 years ago
12 years ago

People

(Reporter: Alex, Unassigned)

Tracking

({testcase})

Trunk
x86
FreeBSD
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.6) Gecko/20040423
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.6) Gecko/20040423

This page (like all others) contains tree rows that are implemented useing CSS. 
The problem is that a table doesn't get in the rigth place using margin-left
(CSS variable) if a block element is left of it. This causes the page unreadable.


Reproducible: Always
Steps to Reproduce:
1. Have a table and set CSS variable margin-left
2. Have a DIV element in that space
3. Have the table rigth next to it.

Actual Results:  
Your table is more to the rigth than it should.

Expected Results:  
It should start at the margin-left point.
(Reporter)

Comment 1

14 years ago
Created attachment 153889 [details]
Layout shown correctly in Opera
(Reporter)

Comment 2

14 years ago
Created attachment 153890 [details]
Layout shown incorrectly in Mozilla
(Reporter)

Comment 3

14 years ago
Firefox (v0.9.1) has exacly the same problem.

Comment 4

14 years ago
Can you provide a minimized testcase for this
(http://www.mozilla.org/newlayout/bugathon.html). Thanks

Bernd
The URL doesn't work.  Please attach a testcase.
(Reporter)

Comment 6

14 years ago
A simple test case can be found here: http://www.kruijff.org/alex/Testcase1.html
It should be noted that this isn't exacly the same (i.e. the problem is the same 
but the output is just a little bit differently.)

Comment 7

14 years ago
Created attachment 153970 [details]
testcase

Updated

14 years ago
Keywords: testcase

Comment 8

14 years ago
Created attachment 153972 [details]
further reduced testcase

Comment 9

14 years ago
I see this on LInux 2004100506
The problem seems to be that Moz is treating the table like an inline box and
starting the margin at the right of the left float.
A work around is put a table in a DIV and apply the margins and width to the DIV.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This bug is invalid.  See CSS2.1 section 9.5:

  The margin box of a table, a block-level replaced element, or an element in the
  normal flow that establishes a new block formatting context (such as an element
  with 'overflow' other than 'visible') must not overlap any floats in the same
  block formatting context as the element itself.

So the layout is correct.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.