Attachments missing in saved message

RESOLVED DUPLICATE of bug 193281

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 193281
14 years ago
14 years ago

People

(Reporter: Simon Umbricht, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

When i save a message with attached pictures to foo.eml and open foo.eml,
firefox won't display any of the images.

According to the size of foo.eml, the images should be included as well.

Reproducible: Always
Steps to Reproduce:
1. Save any message containing attached image to a file
2. Open that file in Thunderbird

Actual Results:  
Images attached to the message are not displayed, while the text part of the
mail is shown.

Comment 1

14 years ago
Same thing in Mozilla Navigator. Dupe of Bug 174692? 

(In reply to comment #0)
> When i save a message with attached pictures to foo.eml and open foo.eml,
> firefox won't display any of the images.
...
> Steps to Reproduce:
> 1. Save any message containing attached image to a file
> 2. Open that file in Thunderbird
I guess you mean Firefox, right? 
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> I guess you mean Firefox, right? 

No, I DO mean Thunderbird. The problem I have is when saving a received E-Mail
message to a file. I guess you confused this with saving a webpage to a file.


But I have to add something to my bug description...

The problem even occurs when the attachment is not an image. In this case, the
filename is displayed in bold print, but there's no way to actually open it. As
I said, the file should be saved in the .eml file as well, according to its size.
Summary: Broken images in saved message → Attachments missing in saved message

Comment 3

14 years ago
(In reply to comment #2)
> No, I DO mean Thunderbird. The problem I have is when saving a received E-Mail
> message to a file. I guess you confused this with saving a webpage to a file.
No, I'm not confused. With Mozilla you can open EML in the Navigator and
Mail&News and there is the mentioned bug. And it really looks like a dupe. See
bug 193281 comment 17 (and the previous comment). Other, older TB bug about
this: Bug 239685. So at least you could dupe it against that bug if you agree. 

> I said, the file should be saved in the .eml file as well, according to its size.
It is.
(Reporter)

Comment 4

14 years ago

*** This bug has been marked as a duplicate of 193281 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.