Closed Bug 252458 Opened 20 years ago Closed 20 years ago

Minimum font size should affect line-height

Categories

(Core :: Layout: Text and Fonts, enhancement)

x86
FreeBSD
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 158868

People

(Reporter: ats-mozilla, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.5) Gecko/20031207
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.5) Gecko/20031207

Many (misguided) web designers like to set absolute font sizes in pixels. In
order to make their pages readable for me, I've got my minimum font size set to
15pt. This works most of the time, except when they've also set a line-height in
pixels: if they specify "font-size: 10px; line-height: 13px;", then I end up
with 15px text with a 13px line height, and the result isn't terribly readable.

Reproducible: Always
Steps to Reproduce:
1. Set your minimum font size in the Fonts preferences to 15pt or larger.
2. View a web page (such as http://offog.org/stuff/lineheight.html) that
specifies a line-height smaller than 15px.


Actual Results:  
The lines of text overlap.

Expected Results:  
I'd prefer it if Gecko increased the line-height in this case so that lines of
text don't overlap. Two possibilities would be to increase it to the equivalent
of the minimum font size, or to increase it to (actual-size *
(specified-line-height / specified-size)).

(In the second case, a really enthusiastic developer could find the smallest
font size specified on the page, assume that that correponds to Mozilla's
user-specified minimum font size, and scale all the other font sizes on the page
in proportion -- but that's probably a different feature request...)

This happens in both Mozilla and Firefox.
WFM. You are using a very old build. Fixed long ago, in bug 158868. The fix was
disapproved as blocking Mozilla 1.5. Please try a later release.

*** This bug has been marked as a duplicate of 158868 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.