"Mail to bug owners" link doesn't work properly with Outlook

RESOLVED INVALID

Status

()

Bugzilla
Email Notifications
--
minor
RESOLVED INVALID
14 years ago
5 years ago

People

(Reporter: Paul, Assigned: justdave)

Tracking

2.16.4
x86
Windows 2000

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322)
Build Identifier: Bugzilla Version 2.16.4

This page has a "Send Mail to Bug Owners" link that doesn't seem to work with 
multiple addresses.  The problem seems to be that a comma is used instead of a 
semi-colon.
FROM:
<a 
href="mailto:aaa@widget.com,bbb@widget.com,ccc@widget.com,ddd@widget.com">Send 
Mail to Bug Owners</a>

TO:
<a 
href="mailto:aaa@widget.com;bbb@widget.com;ccc@widget.com;ddd@widget.com">Send 
Mail to Bug Owners</a>

I am using Micro$oft Outlook 2000 SP3.

Reproducible: Always
Steps to Reproduce:
1. Make a query with multiple people on the list
2. press "Send Mail to Bug Owners"
Actual Results:  
all of the email addresses munged together

Expected Results:  
an email addressed to all bug owners on the list
(Reporter)

Updated

14 years ago
Version: unspecified → 2.16.4
Taking a look at RFC 2368 (http://www.ietf.org/rfc/rfc2368.txt) it would appear
this is Outlook's problem.  The mailto: URL scheme does indeed allow for a
comma-separated list of addresses.  In fact, it's specifically used as an
example in the RFC.  I would file a bug with Microsoft.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

14 years ago
Yes you are right.
There is an "option" in outlook to allow commas as address separators

If anyone else has this problem look here:
Tools->Options->Preferences tab->Email Options->Advanced Email Options->Allow 
Comma as address separator check box.
fixing summary to make it easier to find
Summary: Web mail button formatted incorrectly → "Mail to bug owners" link doesn't work properly with Outlook
(Reporter)

Comment 4

13 years ago
*** Bug 316831 has been marked as a duplicate of this bug. ***
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.