Default download to desktop uses wrong folder when user personalize windows for desktop folder location

VERIFIED DUPLICATE of bug 228977

Status

()

Toolkit
Downloads API
VERIFIED DUPLICATE of bug 228977
14 years ago
10 years ago

People

(Reporter: sorriso, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.7) Gecko/20040707 Firefox/0.9.2

If you personalize windows to locale desktop folder in a folder other than the
default

“C:\Documents and Settings\USER NAME\Desktop”

For example, you moved desktop to:
“D:\Desktop”

Download Manager still use “C:\Documents and Settings\USER NAME\Desktop” as
download folder.

I have moved desktop folder before installing Firefox

Firefox should ask the OS where the desktop folder is instead of use the default
location.

Regards

Sorriso
From Brazil


Reproducible: Always
Steps to Reproduce:
1. move desktop folder to a non default location
2. use download to desktop feature
3. 

Actual Results:  
the file is download to the wrong folder, the desktop default location

Expected Results:  
Firefox should ask the OS where the desktop folder is instead of use the default
location.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 228977 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.