favicon not stored in bookmarks for some sites

VERIFIED WORKSFORME

Status

()

Firefox
Bookmarks & History
VERIFIED WORKSFORME
14 years ago
10 years ago

People

(Reporter: Dennis Jacobfeuerborn, Unassigned)

Tracking

({helpwanted, testcase})

Trunk
x86
All
helpwanted, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040721 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040721 Firefox/0.9.1+

For some sites the favicon does not get stored in the bookmarks. Example sites:
www.groklaw.net, www.slashdot.org, theregister.co.uk . The icon gets displayed
in the url widget and on the tab but not stored in bookmarks.html. For other
bookmarks the favicons get stored as expected.

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.groklaw.net/
2. Add to bookmarks

Actual Results:  
Favicon gets displayed in url widget and on tab but not stored in bookmarks.


Expected Results:  
Favicon gets stored in bookmarks like icons for most other sites.
(Reporter)

Comment 1

14 years ago
Something I forgot to mention: The bookmark entries that don't store the icon
keep their default "sheet" icon instead.

Comment 2

14 years ago
I see this too on windows XP pro. 
I see this on www.mcafee.com and www.symnatec.com

Comment 3

14 years ago
indeed, there still are some issues as i pointed out here:
http://bugzilla.mozilla.org/show_bug.cgi?id=252224#c9

Comment 4

14 years ago
Confirming with: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
Gecko/20040719 Firefox/0.9.1+
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In repply to comment #0)
> Reproducible: Always
> Steps to Reproduce:
> 1. Go to http://www.groklaw.net/
> 2. Add to bookmarks

Note that the icon for the bookmark will not get loaded/updated until you either
a) select the bookmark explicitly; or b) (in most cases) switch to another tab
and then switch back to the tab with the bookmarked site.  This is a limitation
of the current way bookmarks are handled, in that the icon isn't passed along
when a site is bookmarked but is only updated the next time a load for that site
is noticed.

> Actual Results:  
> Favicon gets displayed in url widget and on tab but not stored in bookmarks.

It's displayed in the url widget and on the tab, but is not displayed on the
bookmarks toolbar, right?

Can you confirm that this is the case by bookmarking the site, then explicitly
visiting it (again), and checking to see if the icon gets saved?

(In reply to comment #4)
> Confirming with: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
> Gecko/20040719 Firefox/0.9.1+

0719 is a bad build to confirm with, as it still had a bug that caused the
bookmark icons to not save.

(Reporter)

Comment 6

14 years ago
(In reply to comment #5)
> Can you confirm that this is the case by bookmarking the site, then explicitly
> visiting it (again), and checking to see if the icon gets saved?

Deleting the bookmark for groklaw.net and then creating a new one and explicitly
visiting the new bookmark works, i.e. the icon now gets stored. However
explicitly visiting the bookmark doesn't seem to be enough since I still have
problems with e.g. slashdot.org. I guess re-adding that bookmark would fix it
too but I'm not sure if it's a good idea to require users to re-add these
"malfunctioning" bookmarks. Here is my slashdot.org bookmark entry, maybe it
helps to track down what is wrong with it:

<DT><A HREF="http://slashdot.org/" ADD_DATE="1050174870" LAST_VISIT="1090531029"
LAST_CHARSET="ISO-8859-1" ID="rdf:#$RddOn1">Slashdot: News for nerd
s, stuff that matters</A>

Comment 7

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040723
Firefox/0.9.1+

Confirming that re-adding malfunctioning bookmarks _always_ works.

I wonder why this is caused anyway? At first I thought it had something to do
with imported IE favorites (some of them were malfunctioning), but it seems
older Firebird/Firefox bookmarks can have the same troubles as well (I had a
Bugzilla root bookmark which refused to show its icon).

Perhaps that, as a workaround, Firefox 1.0 could include some wizard (visible or
not) on first start that would effectively refresh the whole bookmark list (i.e.
re-add every single one)? This way, people using 0.9.x and having tons of
bookmarks would save a lot of time. Forcing people to do this by hand is _very_
tedious (one bookmark is okay, but five or more is just ridiculous).
patch in on aviary, trunk soon (once bookmarks stuff gets moved over)

http://tinderbox.mozilla.org/bonsai/cvsquery.cgi?module=AviaryBranchTinderbox&branch=AVIARY_1_0_20040515_BRANCH&cvsroot=/cvsroot&date=explicit&mindate=1090724100&maxdate=1090724640&who=vladimir%25pobox.com

However, note that sites with incorrect/bad favicons still might have nothing
displayed in the bookmarks toolbar -- bug 247981 needs to make it to aviary
first, so I can test for valid image content before saving.
(Reporter)

Comment 9

14 years ago
(In reply to comment #8)
> However, note that sites with incorrect/bad favicons still might have nothing
> displayed in the bookmarks toolbar -- bug 247981 needs to make it to aviary
> first, so I can test for valid image content before saving.

What constitutes an incorrect/bad favicon? I just tested the latest nightly
(from 25th) and after visiting the slashdot.org bookmark got updated. However
visiting my plone.org and theregister.co.uk bookmarks still doesn't result in
their favicons beeing updated.
(In reply to comment #9)
> What constitutes an incorrect/bad favicon? I just tested the latest nightly
> (from 25th) and after visiting the slashdot.org bookmark got updated. However
> visiting my plone.org and theregister.co.uk bookmarks still doesn't result in
> their favicons beeing updated.

By incorrect/bad favicon I meant favicons that aren't valid images -- i.e. sites
that return junk for /favicon.ico, or return an error page without also
returning an error code or somesuch.  However, plone.org and theregister have
valid favicons.  Can you copy your bookmarks entries for those sites here?
(Reporter)

Comment 11

14 years ago
Here are the entries for plone and theregister:

<DT><A HREF="http://www.plone.org/" ADD_DATE="1057774403" LAST_CHARS
ET="UTF-8" ID="rdf:#$aA6F+3">plone.org - Welcome to plone.org</A>

<DT><A HREF="http://theregister.co.uk/" ADD_DATE="1050183297" LAST_V
ISIT="1080850324" LAST_CHARSET="ISO-8859-1" ID="rdf:#$VddOn1">The Register</A>
This is working now as tested with the three site originally reported. The
favicons for those sites do appear as expected on revisiting the site. Seen on
0.9+ branch build from 0726.
(Reporter)

Comment 13

14 years ago
I just checked the branch build from the 27th and plone.org works now but
thregister.co.uk still doesn't.

Comment 14

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040727
Firefox/0.9.1+

As a sidenote, b.m.o (any page on the domain, actually) still doesn't give me a
favicon either. Re-adding the bookmark doesn't work, either, as opposed to
comment #7. :-(

<DT><A HREF="http://bugzilla.mozilla.org/" ADD_DATE="1090950182"
LAST_CHARSET="ISO-8859-1" ID="rdf:#$aCkgv2">Bugzilla.m.o</A>

Comment 15

13 years ago
Using the build from 20/8 together with a fresh profile, I am getting no
favicons at all in my bookmarks.

Comment 16

13 years ago
Scratch that earlier comment, a newer build works fine for the most part.

To get a favicon in the bookmark however, I must 1st create the bookmark, and
then revisit the site (refresh, open the bookmark). It is *only on the 2nd page*
load that the favicon 'transfers'.

HTH

Comment 17

13 years ago
(In reply to comment #16)
> Scratch that earlier comment, a newer build works fine for the most part.
> 
> To get a favicon in the bookmark however, I must 1st create the bookmark, and
> then revisit the site (refresh, open the bookmark). It is *only on the 2nd page*
> load that the favicon 'transfers'.
> 
> HTH
confirming what #16 says, only if you have visited a stored bookmark, the
favicon appears.
(Reporter)

Comment 18

13 years ago
It still doesn't work for my http://www.theregister.co.uk/ bookmark in the
latest nightly: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040901
Firefox/1.0 PR (NOT FINAL)

Comment 19

13 years ago
http://www.theregister.co.uk/ works fine for me. Bookmark it, load it once, and
the icon fills in. Mozilla/5.0 (Linux i686; rv:1.7.3) Gecko/20041017 Firefox/1.0

Is this still happening with a clean bookmarks.html, and a recent build?
Assignee: vladimir → vladimir+bm

Comment 20

13 years ago
The favicon shows up on the address bar, but not in the bookmark list - but only
for some sites.  For example, www.nytimes.com shows a favicon in the bookmarks
sidebar but www.cnn.com does not...
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050614
Firefox/1.0+ ID:2005061409

possibly fixed by bug 109672 , i can't reproduce the cases here anymore

Comment 22

12 years ago
*** Bug 307886 has been marked as a duplicate of this bug. ***

Comment 23

12 years ago
This bug still occurs for me. For example:

www.nationalrail.co.uk
www.tvguide.com

Both display the icon but do not store it in the bookmarks toolbar.

Using Firefox 1.07 on XP Pro.

Comment 24

12 years ago
I'm also seeing this bug with SeaMonkey 1.0 branch build 2005101611 on Windows
XP SP2. Deleting and readding the bookmark, then revisiting the site, fixes the
problem in SeaMonkey, too. Should this be changed to a core bug, or should I
file a separate bug for SeaMonkey?

I'm also seeing the problem on these other sites:
http://www.mozilla.org/
http://www.amazon.com/
http://www.adobe.com/
http://www.real.com/
OS: Linux → All
Version: unspecified → Trunk
Assignee: vladimir+bm → nobody

Comment 25

12 years ago
Got the same problem here:
https://messenger.sch.bme.hu/
http://iwiw.net/

Comment 26

12 years ago
Not sure if this will help others or not, but I figured I'd share anyway.  I was using this plugin for the GIMP to make a favicon for my site:
http://registry.gimp.org/plugin?id=6819

The plugin creates an icon file with multiple layers, 9 in total; 3 at 16x16, 3 at 32x32, and 3 at 48x48.  The 3 versions of each size contain layers at different color depths.  When using the 9-layered icon, it would show up in the address bar, but not when I created a bookmark.  After many iterations, I found that removing the 48x48 layers allowed the favicon to be displayed both in the address bar and in a bookmark.

Your mileage may vary, but it did the trick for me!

Comment 27

12 years ago
This bug may be a duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=237158

Comment 28

12 years ago
I still can confirm this behaviour with this site:
http://derstandard.at

Even if I click on the bookmark itself, the icon stays the default favicon. 
I have tried a few of the other links, but they all work for me. 

I use Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks

Updated

11 years ago
Duplicate of this bug: 246946

Comment 31

11 years ago
Created attachment 257016 [details]
Testcase A : favicon is shown in bookmarks

The favicon will be shown in bookmarks (after clicking on the bookmark).

Comment 32

11 years ago
Created attachment 257017 [details]
Testcase B : favicon is NOT shown in bookmarks

The favicon will NOT be shown in bookmarks.
This seems to be because it's a multipart Windows Icon (the favicon from testcase B is also a Windows Icon, but not multipart).

Updated

11 years ago
Keywords: clean-report, helpwanted, testcase

Comment 33

11 years ago
This works for me on all sites listed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3. The only exceptions are sites that have icons that exceed 16kb which are not added to the bookmarks file see bug 252401. eg http://www.nationalrail.co.uk/favicon.ico and comment 32
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Comment 34

11 years ago
Verified WFM with Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3.
Tried with a multipart favicon below 16kb, which doesn't reproduce.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.