Firefox fails to recover when computer comes out of screensaver mode

RESOLVED DUPLICATE of bug 233846

Status

--
major
RESOLVED DUPLICATE of bug 233846
15 years ago
14 years ago

People

(Reporter: cleanthes, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040628 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040628 Firefox/0.9.1

This happens after I have closed all Firefox windows (but kept the application
running) and left my computer long enough for the screensaver to start. When I
resume working on my computer, Firefox fails. 

When I open a new window in the Firefox session that was running, the personal
toolbar disappears and Firefox behaves erratically. When I quit Firefox and
start a new session, then everything is fine. 

I have the adblock and bookmark sorter extensions installed, as well as a whole
bunch of additional search engines from mycroft.mozilla.org in the search bar,
but I can't attribute the bug to either one of these. The bug is there when I
uninstall the extensions and when the only engine in the search bar is google. 

I searched for something similar in the bug list, but I only got zarro bugs found.

Quite a few times after I installed 0.9.1, my computer failed to wake up from
sleep, and I think that was caused by Firefox, tool.

Reproducible: Always
Steps to Reproduce:
1. Start Firefox. 
2. Close all windows but keep session going (Mac only, perhaps), and wait until
screensaver starts and/or computer goes to sleep.
3. Resume work on computer, and open a new window in the previously running
Firefox session.

Actual Results:  
Personal toolbars disappeared, and Firefox behaved erratically--sometimes even
crashed--until it was restarted.

Expected Results:  
remained stable.

Comment 1

15 years ago
Probably dup of Bug 233846, although I can't see this.
(Reporter)

Comment 2

15 years ago
Thank you. It is the same bug.

*** This bug has been marked as a duplicate of 233846 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.