If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

sensitive area for mouseOver is wrong on images with hspace or vspace

RESOLVED INVALID

Status

()

Core
Layout: Images
RESOLVED INVALID
13 years ago
12 years ago

People

(Reporter: mediadesign, Assigned: Blake Ross)

Tracking

({testcase})

1.8 Branch
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.7) Gecko/20040626 Firefox/0.9.1

On the folowing two websites are images, that change onMouseOver. The images
have a padding with hspace and/or vspace. Due to this, the hotspot is, in
addition to the whised one, somewhere close to the padding border.


Reproducible: Always
Steps to Reproduce:
On http://www.enbw.com/berlin/ you see flashing buttons, when moving the mouse
horizontally over the main menu caused by a hspace="1".

On http://www.mompswebdesign.com/dhtml/resize_replace.html the error can be seen
by moving the mouse over the folder image.
Actual Results:  
The hotspot is outside an image.

Expected Results:  
Sensitive area only on the image.

I reproduced this error with Firefox 0.91 on Windows and Linux.
the page claims to be
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
HSPACE and VSPACE are deprecated for this version
->resolved/invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

13 years ago
But how about http://www.mompswebdesign.com/dhtml/resize_replace.html where no
doctype is defined?

Anyway, if you use style="margin-top: 20px; margin-bottom: 20px;" instead of
vspace="20" there will be still the same problem as I reported before.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 4

12 years ago
Hi,

the bug is still reproduceable with Firefox 1.0.7. If I use CSS margin:50px; it
works everywhere as wished except at the bottom, the same with margin-bottom
only. Please note that the mouseOver is only additionally triggered at the
bottom edge of the margin and not on top, left and right margin.

See http://www.viazenetti.de/mouseover.html

I have to admit, that the onMouseOver is in the achor, that encloses the image
that has the margin.
Version: unspecified → 1.0 Branch

Comment 5

12 years ago
Created attachment 198038 [details]
simplified testcase

Testcase using an image that is bigger than the line height inside a link, with
onmouseover/out handlers on the link that change its background to yellow. Due
to its margins, the image extends above the line-height.

That the line (shown in dark gray) is part of the sensitive area sounds
reasonable to me. One can also state that since the image is a child of the
link, it also is part of the sensitive area, even in the part of the image
outside of the regular dimensions of the link (the text line). That would
explain why it seems that the margin bottom of the image is sensitive, but the
margin-top is not: the margin-bottom simply falls into the regular dimensions
of the link (and part of the left/right margins do so, as well).

Can anyone confirm that this is per-specification?

Comment 6

12 years ago
Note that when you increase the text size (using Ctrl-Plus) to the point where
the line height is greater than the image height, all margins around the image
become part of the sensitive area (which fits exactly into the above reasoning).
Yes, I think that Mozilla is behaving correct here.
Keywords: testcase

Updated

12 years ago
Component: General → Layout: Images
Product: Firefox → Core
Version: 1.0 Branch → 1.8 Branch

Comment 8

12 years ago
Resolving.

Reporter, if you find evidence in the HTML/CSS specifications that the behaviour
is wrong, please reopen this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.