popup blocking (dom.popup_maximum) breaks web-apps with multiple windows

RESOLVED DUPLICATE of bug 249979

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 249979
14 years ago
14 years ago

People

(Reporter: Wolfgang Dinstl, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616

This new feature since 1.7 is a serious problem for web-apps, which work with 
multiple windows. The normal way to open a new window in web-apps is 
the "onload"-event in <body>-tag. It is not possible to open a new window 
via "click", because some form-inputs must be checked or validated on server. 
After this checking, the new window can be opened, and this is done 
via "onload". So the counter is incremented every time a new window is opened 
till it reaches the default configuration number of 20. Then every new window 
is blocked. Even if the same window is used (same windowname) the window.open 
is blocked after a while.
THIS MAKES ABSOLUTELY NO SENSE IN CONJUNCTION WITH WEB-APPS!!
Maybe this feature is useful for "normal browsing", but not for web-apps. The 
only workaround for this problem is to set the pref "dom.popup_maximum" to a 
very high value (e.g. 100.000). But this cannot be done via user-interface!
How could this problem be solved?

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
You have a bug open on this: 249979

<http://bugzilla.mozilla.org/show_bug.cgi?id=249979>

Instead of filing a new bug perhaps you should just change the summary in the
original bug to be more specific

*** This bug has been marked as a duplicate of 249979 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.