keira-knightley.org bypasses Firefox popup blocker with onclick popup

RESOLVED DUPLICATE of bug 212163

Status

()

--
major
RESOLVED DUPLICATE of bug 212163
15 years ago
15 years ago

People

(Reporter: marshalus, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040721 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040721 Firefox/0.9.1+

On the page http://www.keira-knightley.org/, someone as figured out how to
bypass the Firefox popup blocker using some kind of popup blocker decector.
http://www.keira-knightley.org/topad.txt seems to be the cause of the popup.

Reproducible: Always
Steps to Reproduce:
Step 1: Goto http://www.keira-knightley.org/
Step 2: Click the '02.multimedia' menu option on the navigation bar.
Step 3: Watch Firefox render a popup.
Actual Results:  
Popup/Popunder rendered.

Expected Results:  
Rendered nothing.
CONFIRMED

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040721
Firefox/0.9.1+

Comment 2

15 years ago
I haven't completely tracked down the code yet, but this popup is happening when
you click on the multimedia link.  It loads a popup in the corner of the screen,
waits a few seconds, then the popup loads an ad and resizes/moves the window.

Don't know if there's anything you can do about that, since disabling any
onclick popups breaks legitimate stuff.

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 212163 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Summary: JavaScript command bypasses Firefox popup blocker → keira-knightley.org bypasses Firefox popup blocker with onclick popup
You need to log in before you can comment on or make changes to this bug.