Closed Bug 252736 Opened 16 years ago Closed 13 years ago

opening ics files with sunbird doesn't work

Categories

(Calendar :: General, defect)

x86
Windows 98
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: Jonathan, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040716 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040716 Firefox/0.8

I'm migrating some of our outlook users to firefox/thunderbird/sunbird and I set
up the remainign outlook users to send events in .ics format. I also sent ics
event from evolution to be sure it was not outlook related: when you open an ics
file with mozillasunbird.exe under windows 98 (test platform) either from
thunderbird or from the filemanager you get always the same error: "c is not a
registered protocol" I guess to fix this sunbird should guess that this is a
file:// url and not a c://.

Then sunbird crashes (it stays in memory and further attempts to do the same
steps just opens a tiny window with nothing in it) and you have to kill the process.

I think this is the only current way to add meetings from e-mail received in
thunderbird so thi is a really important bug for mebefore they start asking me
to put back their outlook.

Reproducible: Always
Steps to Reproduce:
1. right click on an ics attachment in thunderbird
2. select "open with" mozillasunbird.exe
3. an error message "c is not a registered protocol" pops up and sunbird stays
in memory until you kill it

Actual Results:  
The event is not added.

Expected Results:  
The event should be added in your default calendar (with or without asking you).
This is a dupe of 252736
oh my. wrong bug sorry for that!
DUPLICATE 212792
No dup, this is about c:\, other bug is more general.
*** Bug 256337 has been marked as a duplicate of this bug. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true
sunbird doesn't allow a proxy server to be specified to access a remotely stored
 .ics.  sunbird works successfuly on laptop via home broadband connection, am
forced to use mozilla calendar extension with thunderbird to access via office
proxy.

Actually, this does *not* seem to be a duplicate of 212792. 212792 is about 
IMAP. This bug is about opening an .ics file from within Windows Explorer 
after manually associating this file type to Sunbird. Sunbird 0.2 displays the 
exact behavior described below (*). It's possible that a different form of 
association needs to be used or DDE in a specific fashion, but since it's not 
documented I don't know what else to try. I wanted to check against the 
latest "test build", but that happens to bomb out with an error "missing 
msvcrtd.dll". Is that perhaps just a typo and actually should be "msvcrt.dll"?

(*) In addition, I noticed that after killing the task and opening Sunbird 
manually it's got that event and wants me to acknowledge it. So, it indeed 
seems, it's just like the original reporter says: the ability is there but 
Sunbird handles the disk letter as a protocol identifier.
And here's a workaround. Following the missing file:// theory I simply added 
it to the file action, et voila: it works! With a twist, see below. So, this 
bug should be very easy to fix!
Instructions: 
add a file type to Windows Explorer, as action use 
"path to sunbird" "file://%1"
(including the quotation marks).

(*)The caveat is: it works and adds the event, but it also launches *two* 
other Sunbird windows: 
- a completely empty one with no title (sitting "minimized" in the top left 
corner of the screen)
- an acknowledgement window which doesn't seem to be necessary since the event 
shows in Sunbird already, anyway.

It's possible that the additional windows are caused by DDE. Although I 
unchecked DDE several times each time I double-click an .ics file the same 
problem occurs and when I look in the action options DDE got rechecked.
Can someone please report how trunk builds of Sunbird handle this situation?
QA Contact: gurganbl → general
I installed the latest trunk build (27-08-2005) by copying all of it's files 
over the existing 0.2 directory. I downloaded a lightning.xpi as well, but I 
don't know if I need to put it somewhere and if so, where.
It seems that nightly build doesn't work at all, so I can't say how trunk 
builds handle this. However, there is no chance for trunk builds to handle 
this correctly unless there is a correct association (command line) for .ics 
files. And this could only be created by an installer or if there is some 
manual instruction.
BTW: also tried the build one day earlier, same problem. Symptom: double-click 
on sunbird.exe doesn't launch the program. It's not just that the GUI is 
missing, task manager clearly shows, there's no program launch.
BTW: this is on Windows XP SP2 (just noticed that the bug was entered for 
Win98).
Ok, this was obviously the wrong way to install that update. There was some 
interference with an existing file it seems. When I launched it without 
copying over I got at least a debug dialog. So I uninstalled the earlier 0.2 
stable release and used the latest trunk build from its directory. It opens ok 
and gives me a functional program.
However, when I double-click an .ics file the only thing that happens is that 
Sunbird gets launched. The event doesn't get added at all - in other words, 
it's even less functional than before. I also tried with a "normal" command 
line like "C:\Program Files\Mozilla\Sunbird\sunbird.exe" "%1". There is no 
difference. Maybe I need to use a parameter, but since I don't know ...
Adding events from .ics files via "import" does work. I also noticed that the 
menu action "Open calendar file" doesn't do anything, it's dead at the moment.
*** Bug 310788 has been marked as a duplicate of this bug. ***
Reassigning all automatically assigned bugs from Mostafa to nobody@m.o

Bugspam filter: TorontoMostafaMove
Assignee: mostafah → nobody
Patches in Bug 177109 added the -subscribe parameter.
Bug 362285 gives the necessary registry changes.
Depends on: 177109, 362285
Depends on: 212792
WFM now. Can we close it?
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
No longer depends on: 362285
You need to log in before you can comment on or make changes to this bug.