mozilla seems not to support xml 1.1

VERIFIED DUPLICATE of bug 233154

Status

()

VERIFIED DUPLICATE of bug 233154
14 years ago
14 years ago

People

(Reporter: mr, Assigned: hjtoi-bugzilla)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707

I tried to open in mozilla a small file like this:
<?xml version="1.1"?><ActionList Priority="3"></ActionList>

It refuses, with the following error:
XML Parsing Error: syntax error
Location: file:///C:/Documents%20and%20Settings/mr/My%20Documents/test.xml
Line Number 1, Column 16:<?xml version="1.1"?>
---------------^

If I put instead version 1.0, all is fine. I would like to use version 1.1 xml
because it supports an enlarged character set (ie special characters <32) as
explained at http://www.w3.org/TR/2004/REC-xml11-20040204/#charsets

Reproducible: Always
Steps to Reproduce:
1. Create a file with the following content: <?xml version="1.1"?><ActionList
Priority="3"></ActionList>
2. Open it in mozilla
3.

Actual Results:  
I got an error:
XML Parsing Error: syntax error
Location: file:///C:/Documents%20and%20Settings/mr/My%20Documents/test.xml
Line Number 1, Column 16:<?xml version="1.1"?>
---------------^


Expected Results:  
Open it and show this:
<ActionList Priority="3"/>

IE seems to support special chars even in XML version 1 (which seems to be a bug
as it is a 1.1 feature), but does not want to open my file if I tag it as 1.1

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 233154 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.