MIME type "image/vnd.microsoft.icon" is not recognized

RESOLVED FIXED in mozilla1.8alpha3

Status

Core Graveyard
File Handling
--
minor
RESOLVED FIXED
14 years ago
2 years ago

People

(Reporter: Uwe Schröder, Assigned: Biesinger)

Tracking

Trunk
mozilla1.8alpha3
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a3) Gecko/20040723
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a3) Gecko/20040723

Although Mozilla can display Microsoft ".ICO" files as images, it does not
recognize them when they are delivered with the recently registered MIME type
"image/vnd.microsoft.icon"
<URL:http://www.iana.org/assignments/media-types/image/vnd.microsoft.icon>.

This media type should be recognized and handled exactly like the commonly used
but now obsolete "image/x-icon".

Reproducible: Always
Steps to Reproduce:
Follow the link in the URL field.
Actual Results:  
A dialog box pops up saying »The file "clip04.ico" is of type
image/vnd.microsoft.icon, and Mozilla does not know how to handle this file
type« and offers to download it, or to open it with an external application.

Expected Results:  
The file should be displayed in the browser window.


This affects only icon images that are accessed directly from the URL bar.
Favicons and icons used as inline images are displayed properly, regardless of
their MIME type.
Created attachment 154190 [details] [diff] [review]
patch
Assignee: darin → cbiesinger
Status: UNCONFIRMED → ASSIGNED
Attachment #154190 - Flags: superreview?(bzbarsky)
Attachment #154190 - Flags: review?(tor)
Target Milestone: --- → mozilla1.8alpha3
Comment on attachment 154190 [details] [diff] [review]
patch

sr=bzbarsky
Attachment #154190 - Flags: superreview?(bzbarsky) → superreview+

Updated

14 years ago
Component: Networking → File Handling
QA Contact: benc → ian

Updated

14 years ago
Attachment #154190 - Flags: review?(tor) → review+
Checking in modules/libpr0n/build/nsImageModule.cpp;
/cvsroot/mozilla/modules/libpr0n/build/nsImageModule.cpp,v  <--  nsImageModule.cpp
new revision: 1.12; previous revision: 1.11
done
Checking in xpfe/components/build/nsModule.cpp;
/cvsroot/mozilla/xpfe/components/build/nsModule.cpp,v  <--  nsModule.cpp
new revision: 1.43; previous revision: 1.42
done
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
*** Bug 277535 has been marked as a duplicate of this bug. ***
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.