options in some listboxes only highlighted to text width, not listbox width

RESOLVED FIXED

Status

()

RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: dbaron, Assigned: roc)

Tracking

({regression, testcase})

Trunk
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

This is a regression from bug 232540.  Some options in listboxes are only
highlighted to the text width, not the listbox width.

Steps to reproduce:
 1. load http://bugzilla.mozilla.org/enter_bug.cgi?product=Browser
 2. Click on "Trunk" in the "version" listbox at the upper left.

Actual results:  Highlighting is only the width of "Trunk" with a little padding

Expected results: Highlighting should be the width of the listbox.
Strange. Most listboxes seem to work

Comment 2

15 years ago
WFM using 7/23-07 with XP.
*** Bug 252932 has been marked as a duplicate of this bug. ***
Created attachment 154301 [details]
Testcase

This bug seems to occour when the entries in the listbox are exactly as high as
the listbox is. If there are fewer entries, the bug doesn't occour, when there
is a scrollbar, the bug doesn't occour.
Keywords: testcase
Summary: some options in listboxes only highlighted to text width, not listbox width → options in some listboxes only highlighted to text width, not listbox width
Okay, that checkin was wrong because it allows a reflow at unconstrained width
(to determine intrinsic width) which is not followed by any reflow at
constrained width ... this should never happen. In this case the blocks are
never given a width constraint to reflow to.

I think I should just backout that checkin. Fixing the minor underlying bug
there (which AFAIK has never been reported) can wait until I've rewritten
scrollframes to make scroll layout sane(r).
okay, I backed that out.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.