All users were logged out of Bugzilla on October 13th, 2018

Undo problems with edit fields

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: norbert.notz, Assigned: mozeditor)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.8a3) Gecko/20040722 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.8a3) Gecko/20040722 Firefox/0.9.1+

The following problem can be reproduced with all edit-fields of Firefox, for
example the address bar, the search bar, form input fields or the search field
(CTRL+f):

- enter "1111"
- press CTRL+a
- enter "2222"
- press CTRL+a
- enter "3333"
- richt-click "Undo": "3" is shown: This makes no sense because we never have
confirmed a single "3"!
- again richt-click "Undo": "2222" is shown.
- again richt-click "Undo": "2" is shown: The same problem as with the single "3"
- again richt-click "Undo": "1111" is shown"
- again richt-click "Undo": the field is empty.


So we can undo all steps icluding some buggy intermediate steps.

But we cannot redo!

In my oppinion you should fix this so that only one step can be undone and the
next undo does undo the undo, which means it restores the value before the first
undo :-) This would be enough for input fields and fix the problem that all can
be undone but not restored. MS does so in Notepad. :-)
And you should make sure that undo correctly works, I mean the buggy
intermediate steps that restore single digits in above description...

Reproducible: Always
Steps to Reproduce:
confirming (the undo part)

->NEW

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040723
Firefox/0.9.1+
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

14 years ago
(In reply to comment #0)

sorry for the typing errors:

"richt-click"->"right-click"

Comment 3

14 years ago
-> editor: core
Component: General → Editor: Core
Product: Firefox → Browser
Version: unspecified → Trunk

Updated

14 years ago
Assignee: firefox → mozeditor
QA Contact: firefox.general → bugzilla
(Reporter)

Comment 4

14 years ago
(In reply to comment #0)

> In my oppinion you should fix this so that only one step can be undone and the
> next undo does undo the undo, which means it restores the value before the first
> undo.
...
> MS does so in Notepad.

"Notepad" was a bad example. But MS does so in it's edit-fields! And you should
do the same because it's more intuitive than you do currently (allowing multiple
undo steps but no redo steps). 

(Reporter)

Updated

14 years ago
OS: Windows 95 → Windows XP

Comment 5

12 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060629 Minefield/3.0a1
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.