1.8a2 composer makes errors when editing

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
14 years ago
5 years ago

People

(Reporter: joe, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a2) Gecko/20040714
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a2) Gecko/20040714

The latest Composer module makes html errors when editing pages. These same
errors were NOT in 1.5 composer and down but gegan in 1.6 and now make composer
virtually unusable in many applications.  Please see for example:
http://gpsinformation.net/bannerroll.htm

For examples:
1) This page has banners at the top of the page (just ignore these).  Look at
the text at the bottom.  Note that some of the lines have MULTIPLE "bullets". 
The extra bullets appear when you add a new line of text with a horizontal line
separator.  
2) After I edit and add a new entry line,  a SECOND FULL COPY of the entire text
section magically appears.  
3) Many extra characters including lots of <> appear in the edited versions when
the copy is displayed on other browsers such as Internet Explorer.  The extra
html must be manually edited out.




Reproducible: Always
Steps to Reproduce:
1.see above
2.
3.

Actual Results:  
text displayed as described.

Expected Results:  
should have worked as in the past versions and be compatible with IE6.

Comment 1

14 years ago
dup of bug 251686? Bug 251686 is fixed in builds from July 22nd and later.
Can you try one of those?
Summary: 1.8a2 composer makes errors when editing → 1.8a2 composer makes errors when editing
(Reporter)

Comment 2

14 years ago
I am now using a nightly build from July 31 2004 and it still has problems as
outlined before:
1) If in the sample file,  you try to ADD another "classified entry with a
"bullet" and a horizontal line as shown at http://gpsinformation.net/bannerroll.htm
then Composer adds extra CR/LF  and puts the bullet at the wrong place.  If I
"fiddle" with it for awhile, I can get things looking pretty good.  
2) As an exercise,  try and REMOVE the extra "bullets" Composer has added.
3) As another exercise, try and add ANOTHER line of text (in the middle of what
is there) and with a "bullet" which should automatically be generated by a CR
following the existing line.  

Fun!  I sure wish this could be fixed!

I think that the extra "internal" CR/LFs are no longer generted by every edit, 
but composer DOES generate extra CR/LFs in the output HTML.

Thanks.  
Product: Browser → Seamonkey
(Reporter)

Comment 3

14 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

14 years ago
Whiteboard: DUPEME
Can you reproduce with SeaMonkey v1.1.9 ?
Assignee: composer → nobody
QA Contact: composer

Comment 5

10 years ago
Serge, reporter no longer uses SM.
(I'm not sure whether the steps are detailed enough.
Anyway, I don't expect much Composer work to happen before bug 477840 is completed...)

Comment 7

6 years ago
WFM on trunk, when adding new lines on provided page no extra bullets or other editing artifacts observed
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 SeaMonkey/2.13a1
Build identifier: 20120712003002
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.