nsWebBrowserFind::GetFrameSelection triggers assertion in nsFrameManager.cpp

RESOLVED FIXED

Status

()

Core
Selection
--
minor
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: mats, Assigned: mats)

Tracking

({testcase})

Trunk
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Assignee)

Description

14 years ago
nsWebBrowserFind::GetFrameSelection triggers assertion in nsFrameManager.cpp

STEPS TO REPRODUCE:
1. Load testcase in a debug build
2. Context menu: "Select All"
3. Context menu: "View Selection Source"

ACTUAL RESULTS:
WARNING: NS_ENSURE_TRUE(aContent) failed, file nsFrameManager.cpp, line 403
WARNING: NS_ENSURE_TRUE(aContent) failed, file nsFrameManager.cpp, line 403

The problem is that nsWebBrowserFind::GetFrameSelection assumes that
focusController->GetFocusedElement returns a non-null value.
There is actually no harm done in this case, but unnecessary assertions
distracts from real ones, IMO.
(Assignee)

Comment 1

14 years ago
Created attachment 154273 [details]
Stack
(Assignee)

Comment 2

14 years ago
Created attachment 154274 [details] [diff] [review]
Patch rev. 1
(Assignee)

Updated

14 years ago
Attachment #154274 - Flags: superreview?(bzbarsky)
Attachment #154274 - Flags: review?(bzbarsky)
(Assignee)

Comment 3

14 years ago
Created attachment 154275 [details]
Testcase
(Assignee)

Updated

14 years ago
Keywords: testcase
Comment on attachment 154274 [details] [diff] [review]
Patch rev. 1

r+sr=bzbarsky
Attachment #154274 - Flags: superreview?(bzbarsky)
Attachment #154274 - Flags: superreview+
Attachment #154274 - Flags: review?(bzbarsky)
Attachment #154274 - Flags: review+
(Assignee)

Comment 5

14 years ago
Checked in 2004-08-08 10:18 PDT

-> FIXED
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Summary: [FIX] nsWebBrowserFind::GetFrameSelection triggers assertion in nsFrameManager.cpp → nsWebBrowserFind::GetFrameSelection triggers assertion in nsFrameManager.cpp
You need to log in before you can comment on or make changes to this bug.