If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

New window opens with a new set of homepages

RESOLVED DUPLICATE of bug 187573

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 187573
13 years ago
12 years ago

People

(Reporter: Carlos Ribeiro, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

When I open a new window (using File:New Window), it opens the full set of home
pages again on the new browser instance.

Reproducible: Always
Steps to Reproduce:
1.Open Firefox
2.Select File|New Window


Actual Results:  
The new browser opens with the set of home pages opened again.

Expected Results:  
There are a few situations to cover:

- File|New Window should open a new browser window with a blank page; the user
can click the Home icon to reopen the homepages.  It's a good balance between
convenience and consistency.
- The right-click (context) menu should include a option to open the current
page in a new window (there is no such option now).

While not really a bug, this behavior is not useful, and it can become quite
annoying if you have a sizeble set of pages on your home setting, and if you
open a new window (accidentally or not). If you just want a new browser window
to do something different in a 'clean' environment, you have to close all the
tabs before starting again.

Also, there is question whether the new browser should open with the current
page already opened (not the one set as the home page).

And finally, there is no option to open the current page in a new browser window
in the right-click (context) menu - although this is another bug (I'll fill it
later).

For the lack of better comparison, here is what IE does. When you open the
browser for the first time, it
(Reporter)

Comment 1

13 years ago
Oops. My comments were truncated. 
IE does the following:

- If you open it from the taskbar or the menu, it shows the home page.
- If you select File|New Window, it opens a new window with the current page in
it (not the home page one).

Comment 2

13 years ago
Making a new window appear blank would be pretty inconsistent behavior, IMHO.

There is a "Clone Window" extension which might help you, though, as it does
exactly as it's called.

Comment 3

13 years ago
Suggesting this be marked as a duplicate of bug #187573.
(Reporter)

Comment 4

13 years ago
I mostly agree with the comments made up to now, but I have to add a few remarks
of myself.

It's difficult to decide between 'consistent behavior' and 'useful behavior'
when dealing with the New Window command in a tabbed-browsing enabled world.
What is more consistent? Sure, always open the home page. But is this useful?
For most people, I don't think so. *If* you ever open a second window, it is
probable that you want to to start working at something else, not to browse to
the same sites again. Obviously, I understand that there may be situations where
this may be useful, but again - I don't think it's useful for the average user.

Said that, the options are:

#1 (Firefox behavior) Open the homepage (or set of home pages) whenever a 
   new browser window is opened.

#2 (IE behavior) Clone the current opened window. I believe this is more 
   useful for the average user than #1.

   (BTW, this problem is not an issue with IE because it does not support 
    tabbed browsing).

#3 (My proposal) Let's call it 'smart mode': 

  (a) open the homepage when the first browser instance is called; 
  (b) open a new window with a blank page if the user (the user can
      always click the home icon to reload the homepage pretty quickly);
  (c) implement a Clone Window command, both on the File menu and on the
      context menu.

I believe my proposal is *more useful*, and it does make sense once you start
thinking not about the behavior of the browser, but about *what does the user
want* when asking for a new window to be opened. (in other words, it's more
consistent from the user standpoint).

PS: and please, verify this bug again. I really believe the current behavior is
annoying.
(Reporter)

Comment 5

13 years ago
Please. Really please. The more I try, the more inconsistent I think tabbed
browsing is behaving on fringe cases. I've decided *not* to open a new bug for
something closely related to this bug, because it seems that this is not a
priority now (for what I have detected looking at the way other similar
complaints are being handled). And I found no reference to a good mailing list
to post my complaint, so here it is.

--> if I click the home button, the browser will open the homepages on new tabs.
--> BUT, if I click a bookmark that has mutiple tabs, they're opened over the
existing ones.

Now, that's inconsistent or not?
I don't feel like searching for all of the relevant bugs right now.

Having a pref for behaviour with new/tabs windows is a dupe of 187573, without a
doubt.  The decision was made, for most users this isn't an issue.  More users
are concerned with limiting the number of windows instead.

clone window on "new window" is a different bug.

comment 5 is yet another bug, which should be fixed at some point to honour the
replace vs. append pref.

Please don't make this into a huge argument.  You've made your point, but its
not strong enough to overrule the decision to not complicate this type of operation.

*** This bug has been marked as a duplicate of 187573 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

13 years ago
Don't worry - I agree with you. I'm not going to make this a big argument. I
just want to make a final comment before putting this to rest.

The only thing which I disagree is with your statement regarding "what most
users want". Well, I'm alone in this - now - but I think that the situation will
change a lot after 1.0 is released. At this point there will probably a
migration of new users to Firefox, and some things that are not important now
may prove important to them in the near future.
You need to log in before you can comment on or make changes to this bug.