bonsai diffs looks doublespaced (extra newlines)

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
14 years ago
2 years ago

People

(Reporter: mvl, Assigned: timeless)

Tracking

Details

(URL)

Attachments

(3 obsolete attachments)

see url. There are newlines that should not be there.

Comment 1

14 years ago
Created attachment 154308 [details]
Testcase

The problem is the <pre>....</pre> around the baaaah, if you remove it,
everything is ok.
(Reporter)

Comment 2

14 years ago
Might be a regression from bug 101084. adding patch author and reviewers.
from build i had locally: regressed between 20040710 and 20040719

Updated

14 years ago
Keywords: regression, testcase
Doesn't IE show the same space?  In other words, isn't bonsai depending on a
Mozilla quirk that no other browser has?
Keywords: regression, testcase
bonsai used to depend on a Netscape 4 bug about unterminated PRE elements not
having a bottom margin.  I thought that was fixed by adding CSS to bonsai to
remove the margin, but I guess not.  This should probably be fixed in bonsai.

Comment 5

14 years ago
Comment on attachment 154308 [details]
Testcase

this testcase is wrong
Attachment #154308 - Attachment is obsolete: true

Comment 7

14 years ago
-> bonsai
Component: Layout → Bonsai
OS: Linux → All
Product: Browser → Webtools
Hardware: PC → All

Updated

14 years ago
Assignee: nobody → tara
QA Contact: core.layout → timeless
(Assignee)

Comment 8

14 years ago
Created attachment 154341 [details] [diff] [review]
close pre, td

this doesn't address the possible <font> tag.

and i can't test it because landfill is being mean to me.
Assignee: tara → timeless
Status: NEW → ASSIGNED
(Assignee)

Updated

14 years ago
Attachment #154341 - Flags: review?(kiko)

Comment 9

14 years ago
Comment on attachment 154341 [details] [diff] [review]
close pre, td

Doesn't this just make it display consistently wrong on all browsers?
(Assignee)

Updated

14 years ago
Attachment #154341 - Attachment is obsolete: true
Attachment #154341 - Flags: review?(kiko)
(Assignee)

Comment 10

14 years ago
well. if someone wants this fixed, they're going to have to provide css that fixes it.
(Reporter)

Comment 12

14 years ago
cvsblame also has empty spaces.
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/README.txt
look between the blocks
(Assignee)

Comment 13

14 years ago
Created attachment 154927 [details] [diff] [review]
pre { margin: 0 }

Comment 14

14 years ago
Comment on attachment 154927 [details] [diff] [review]
pre { margin: 0 }

-> this is my first review on Bonsai, timeless made me do it.

-> dbaron's CSS looks good to me, and converting escaped CAPITALIZED code into
nicely-quoted, xhtml w3c compliant code is always a step in the right
direction.

-> I wonder if it wouldn't have been more useful to create a .css file in which
to specify this rather then using the specification inside the <style> tag of
the HTML. I also am reluctant about mixing CSS and HTML color (and such)
properties for the body tag in the same file.

But I guess we can take imcremental steps towards the right direction, so
r=vladd.
Attachment #154927 - Flags: review+
(Assignee)

Comment 15

14 years ago
mozilla/webtools/bonsai/cvsview2.cgi 	1.33
mozilla/webtools/bonsai/cvsblame.cgi 	1.40
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 16

14 years ago
Comment on attachment 154927 [details] [diff] [review]
pre { margin: 0 }

>Index: cvsview2.cgi
>+    print qq|
>+<html><head>
>+<title>$opt_file: $opt_rev1 vs. $opt_rev2</title>
>+<style type="text/css">
>+pre {
>+    margin: 0;
>+}
>+</style>
>+<body bgcolor="$diff_bg_color" text="#000000"

Unless I'm reading this thing wrong, You've forgotten to add a </head> there
before the body tag. Can someone take care of that?

Comment 17

14 years ago
So it's not forgotten.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 18

14 years ago
And what about closing the <pre> and <td> tags which were originally broken?
</head> is optional, fwiw...
Bonsai.mozilla.org has not been updated since March 23, 2004.

The attached link here displays as single-spaced in Safari 1.2.2, MacIE 5.2.2,
and Firefox 0.9.1.

Sure this isn't a browser bug?  If the behavior is relying on an old NS4 bug, it
seems all the major browsers for OS X have the same bug.
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&root=/cvsroot&subdir=mozilla/security/nss/lib/pk11wrap&command=DIFF_FRAMESET&root=/cvsroot&file=pk11cert.c&rev1=1.131&rev2=1.132
looks double spaced with a recent nightly build of moz 1.8a3
but looks AOK with moz 1.7 RTM, and other browsers,
so is this a bonsai bug? or a browser bug?

Comment 22

14 years ago
For those people who jumped in without reading the bug: Old versions of Mozilla
had a quirk whereby any <PRE> in a table cell had no bottom margin. While this
made bonsai look good, it broke sites with well-formed HTML. Compare this to
Netscape 4's quirk whereby an unclosed <PRE> has no bottom margin.
(In reply to comment #22)
> For those people who jumped in without reading the bug: Old versions of Mozilla
> had a quirk whereby any <PRE> in a table cell had no bottom margin. While this
> made bonsai look good, it broke sites with well-formed HTML. Compare this to
> Netscape 4's quirk whereby an unclosed <PRE> has no bottom margin.

And for those that didn't read the comment I just posted, it looks fine in every
browser I have, so you're telling me every browser out there has this same bug?

Comment 24

14 years ago
No, they simply go to great lengths to copy Netscape 4's bug that makes bonsai
look the way you want it to instead of the way it really is.
(In reply to comment #24)
> No, they simply go to great lengths to copy Netscape 4's bug that makes bonsai
> look the way you want it to instead of the way it really is.

isn't that the point of quirks mode, to emulate NS4?  or is Bonsai suddenly
rendering in strict mode?
It's definitely a bug in bonsai.

You can argue all you want about whether it's a bug in the browser.  There's
certainly no specification that says so.  This is only one of two sites I've
ever seen it on, and the other one is 404 and probably has been for years. 
Based on that, there's no way we're spending the weeks that it would take to
emulate the quirk correctly (which would, incidentally, make us nonconformant
with HTML4, a spec with scandalously few conformance requirements, in a pretty
significant way).
(Well, technically, fixing this case of the bug wouldn't make us nonconformant
with HTML4, but fixing the case in the site in bug 47793, which involves fully
valid markup that shows the same underlying bug, would make us nonconformant.)
(Assignee)

Comment 28

14 years ago
Comment on attachment 154927 [details] [diff] [review]
pre { margin: 0 }

mozilla/webtools/bonsai/cvsblame.cgi	1.40
mozilla/webtools/bonsai/cvsview2.cgi	1.33
Attachment #154927 - Attachment is obsolete: true
QA Contact: timeless → bonsai
Bonsai was decommissioned, closing all remaining bugs "wontfix"
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago2 years ago
Resolution: --- → WONTFIX
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.