Aviary branch builds do not run under Windows NT (or Windows 95)

RESOLVED FIXED

Status

()

Firefox
General
--
blocker
RESOLVED FIXED
13 years ago
11 years ago

People

(Reporter: WG9s, Assigned: Blake Ross)

Tracking

({fixed-aviary1.0, smoketest})

1.0 Branch
x86
Windows NT
fixed-aviary1.0, smoketest
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.19 KB, patch
Brian Ryner (not reading)
: review+
Details | Diff | Splinter Review
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040724 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040724 Firefox/0.9.1+

The code checked in to correct the dependency on SHGetSpecialFolderPath
introduced by the fix for bug 246616 has been checked into the trunk but not the
Aviary branch.  Without this checkin FIrefox will not run under either Windows
NT or Windows 95.  The code required to fix this is:

http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/modules/libpr0n/decoders/icon/win&command=DIFF_FRAMESET&file=nsIconChannel.cpp&rev1=1.36&rev2=1.37&root=/cvsroot

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
(Reporter)

Updated

13 years ago
Flags: blocking-aviary1.0RC1?
Flags: blocking-aviary1.0?
(Reporter)

Comment 1

13 years ago
Please do NOT dupe this bug to 246616 without either.
A.  Checking in t the fix or
B.  Adding "needed-aviary1.0" to the status whiteboard for bug 246616.

(sorry for bugspam,  just thought something was needed to document the need for
a fix for this or it would just get lost and not make the release).

Comment 2

13 years ago
confirming.
Severity: normal → blocker
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Aviary branch builds do not run under either Windows NT or Windows 95 → Aviary branch builds do not run under Windows NT (or Windows 95)
Version: unspecified → 1.0 Branch

Comment 3

13 years ago
If NT is supported, then this is a smoketest blocker.
Keywords: smoketest

Comment 4

13 years ago
fix at bug 246616?

Comment 5

13 years ago
Taking away blocking-aviary requests, since this is a smoketest blocker.
Flags: blocking-aviary1.0PR?
Flags: blocking-aviary1.0?
(Reporter)

Comment 6

13 years ago
re comment #4.  It is not really clear to me that the final fix for the issue is
actually completely contianed in the patches attached to bug 246616.  Neil
checked in a fix with no bug number that is what fixed it so the turnk builds
now work corrrectly with windows NT.  He did post a commnet to bug 246616 saying
he fixed it but the checked in code looks different than the patches that are
attached to the bug.  I think what is required is to make this area of
nsIconChannel.cpp on the Aviary branch be the same a s the current trunk code.

Adding Neil to the cc list to see if he can lend help to fixing this.

Comment 7

13 years ago
Created attachment 154520 [details] [diff] [review]
patch
Comment on attachment 154520 [details] [diff] [review]
patch

r=ben from bryner's machine
Attachment #154520 - Flags: review+
checked in.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed-aviary1.0
Resolution: --- → FIXED

Comment 10

13 years ago
(In reply to comment #3)
> If NT is supported, then this is a smoketest blocker.

Asa, could you take a look at bug 249593 and bug 248509 ? They may be smoketest
blockers too. They only happen on a subset of NT setups, the ones without IE
installed or without the latest service packs, but still are blockers for some
people (see bug 248479 for instance). Thank you.

Comment 11

13 years ago
*** Bug 253456 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.