Closed Bug 253158 Opened 17 years ago Closed 17 years ago

Focus is lost when loading a page in a background tab

Categories

(Firefox :: Tabbed Browser, defect)

x86
All
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 124750

People

(Reporter: bryner, Assigned: bugs)

Details

Steps to reproduce the bug:

1. Load a page.  I suggest one on a server that isn't the fastest to respond so
you'll have a little time during the load. 
http://tinderbox.mozilla.org/showbuilds.cgi?tree=SeaMonkey works well.

2. Open a new tab.  Load any page.  I used http://www.yahoo.com/.

3. Switch back to the original tab using ctrl+pgup.  Tab a couple of times so
that a link on the page is focused.  Hit Ctrl+R to start reloading the page, and
then immediately click on the second tab.

4. Wait for the page in the first tab to finish loading (spinning icon goes away).

5. Switch back to the first tab with ctrl+pgup.  Try to scroll using
pgup/pgdown, or navigate with tab.

Result: nothing happens.  On closer inspection, you seem to be tabbing through
the links in the previous document, not the new one.

Expected results:  Reload should blow away focus memory for the tab.
I think what I experience is the same problem.  

To replicate:
#1.  Go to http://slashdot.org/articles/04/10/03/1230223.shtml?tid=95

#2.  Ctrl-click on the "Clusty" link.  Wait for page to load (should be loading
in background on new tab).

#3.  Hit down arrow key once (with Slashdot page still in focus).

You should see a box pop-up with of all of your previously typed search queries
show up over the Slashdot page.  So even though the Slashdot page should still
be in focus, www.clusty.com's search form now has focus and Firefox has given
textual focus to the clusty page even though you're still viewing the Slashdot page.



Confirm in WinXP as well. This bug has existed in the last many (if not all)
versions of Firefox (at least back to 0.7).

If a page loading in the background issues a focus(), the text cursor is moved
to that tab (in the background). Any site that uses focus() will show this
behavior. Google, for example, does it as well.

The best solution would seem to be to have a separate text cursor
status/location for each tab.
I am experiencing the same problem under XP and 1.0 . It is specially annoying 
because I open my 5 mail acounts at the same time, and ALWAYS a pice of my 
login or password goes into another window.
So the problem is that anyone can grasp pieces of your password just watching 
you typing.
Just to clarify:

The easiest way to reproduce this bug is to open a page, any page, in one tab
and then a page that uses focus() in a second tab (e.g. clusty or google). Once
the command to load the second tab is issued (whether by clicking a bookmark,
pressing enter after typing in an URL or whatever) QUICKLY return to the first
tab. The important thing is just to get back to the first tab before the focus()
is issued, which appears to happen only once the page is completely loaded.

Now type something (or press "down" if you have several entries remembered in
e.g. clusty). The text appears not on the active tab, but on the tab in the
background that issued the focus(). In the case of the "down" button, you
actually get the list of entries showing on the active tab page, not the
background page.

OS should be changed to ALL.

-fyo
OS: Linux → All
isn't this a dup of bug 124750?
Yes, it is.

*** This bug has been marked as a duplicate of 124750 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.