pressing spacebar generates an error in JS console

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
--
minor
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: Nickolay_Ponomarev, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040724 Firefox/0.9.1+ (best browser EVAR1!!)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040724 Firefox/0.9.1+

Pressing spacebar in Extension manager generates an error in JS console:

---
Error: this.selected.pauseResume is not a function
Source File: chrome://mozapps/content/shared/richview.xml
Line: 165
---

looks like a handler is left in richview.xml from DM:
----
<handler event="keypress" key=" " action="if (this.selected) {
this.selected.pauseResume(); }"/>
----

Reproducible: Always
Steps to Reproduce:
1. Open EM
2. Hit spacebar
Actual Results:  
JS console error

Expected Results:  
no JS console error

Comment 1

14 years ago
WFM: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040724
Firefox/0.9.1+
(Reporter)

Comment 2

14 years ago
Sorry, you need to have options.showInConsole=true in about:config; also you
need at least one extension installed. My bad.

Turns out to be a *very* minor issue.

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

14 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050306
Firefox/1.0+
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.