90% of button functionality broken in composer

RESOLVED FIXED

Status

--
blocker
RESOLVED FIXED
15 years ago
14 years ago

People

(Reporter: marcia, Assigned: aaronlev)

Tracking

({smoketest})

Trunk
smoketest

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: http://testrunner.mozilla.org/test.cgi?run_id=261#50)

(Reporter)

Comment 1

15 years ago
Using Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a3)
Gecko/20040726, almost all buttons are not functioning:

Text down and Text Up
Spell Check
Bold
Italicize
Underline
Bullets
Numbering
Table
Images

Asa has confirmed similar behavior using Windows.
Summary: 90% button functionality broken in composer → 90% of button functionality broken in composer
(Reporter)

Updated

15 years ago
Whiteboard: http://testrunner.mozilla.org/test.cgi?run_id=261#50

Comment 2

15 years ago
This is a smoketest blocker for Composer and Mail Compose. It impacts all
platforms and started with the builds on the 25th. The 24th builds seem OK. 
Keywords: smoketest
OS: MacOS X → All

Comment 3

15 years ago
I've been seeing this too. It appears that the act of clicking on one of these
items in the compose toolbar actually moves focus out of the editor instance and
into the subject bar and that's why they appear to not work. 

At least from mail compose that seems to be what's going on. You can see the
cursor move out of the mail body and into the subject box then the compose
toolbar gets disabled because focus isn't in the body....

Comment 4

15 years ago
CC'ing aaronl in case it was his changes (suggested by someone in #dev).
(Assignee)

Comment 5

15 years ago
It's probably me. Does the patch in bug 252984 fix it?

Comment 6

15 years ago
No that patch didn't fix it for me :(. Focus still moved to the subject field
and the compose toolbar remains disabled.
Assignee: composer → aaronleventhal

Comment 7

15 years ago
I checked in attachment 154368 [details] [diff] [review] to fix this.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.