If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Conn: Crash at start w/o internet connection (MacOS only)

VERIFIED FIXED in M14

Status

()

Core
Internationalization
P3
critical
VERIFIED FIXED
18 years ago
16 years ago

People

(Reporter: Adam, Assigned: gordon)

Tracking

({crash})

Trunk
PowerPC
All
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] w/b minus on 03/03)

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
Mozilla-Mac-M13 (01.26.2000) crashes at startup if you don't have an active internet connection. I'm connecting via TCP/IP (PPP - dialup 
internet connection) on PPC G4 OS 9. Happens every time.

MacsBug returns this: PowerPC unmapped memory exception at 71F4FFC0 every time Moz crashes under these circumstances.
(Reporter)

Updated

18 years ago
Severity: normal → major

Updated

18 years ago
Severity: major → critical

Comment 1

18 years ago
Adding "crash" keyword to all known open crasher bugs.
Keywords: crash
(Reporter)

Comment 2

18 years ago
Going to add StdLog from MacsBug of M14 (2000012908) build.



BTW, Bug 25706 is DUP of this one. Going to change it and add 'crash' kywrd b/c it's assigned to nobody and I'm not sure when it's going to get 

looked at. CCing don@netscape.com b/c most of the general crashers have been going to him.

(Reporter)

Comment 3

18 years ago
*** Bug 25706 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 4

18 years ago
Created attachment 4723 [details]
StdLog from MacsBug of M14 (2000012908) crash

Comment 5

18 years ago
Assigning all open "nobody@mozilla.org" bugs to "leger@netscape.com" to weed 
thru.
Assignee: nobody → leger

Comment 6

18 years ago
*** Bug 26114 has been marked as a duplicate of this bug. ***

Comment 7

18 years ago
updating component to Necko.  looks like it's crahsing in nsDNSService.
Assignee: leger → gagan
Component: Browser-General → Networking
QA Contact: nobody → tever

Comment 8

18 years ago
I think gordon has a dup. 
Assignee: gagan → gordon

Updated

18 years ago
Target Milestone: M14

Updated

18 years ago
Keywords: beta1

Comment 9

18 years ago
*** Bug 26130 has been marked as a duplicate of this bug. ***

Comment 10

18 years ago
*** Bug 27570 has been marked as a duplicate of this bug. ***

Comment 11

18 years ago
Moving PDT+ designation from bug 27570.
Whiteboard: [PDT+]

Comment 12

18 years ago
Gordon--to answer your question from the other bug, you are correct in your 
guess:  
  * I haven't had any application make a network connection since I booted my Mac 
  * nor do I have a network connection when I launch mozilla

Hope that is clearer...
(Assignee)

Comment 13

18 years ago
I tried rebooting with no network connection, but I was able to launch and 
shutdown without a crash.  Below is my proposed fix.  Could someone that has a 
build that crashes try it to see if this fixes it?

Index: nsDnsService.cpp
===================================================================
RCS file: /cvsroot/mozilla/netwerk/dns/src/nsDnsService.cpp,v
retrieving revision 1.31
diff -r1.31 nsDnsService.cpp
705,711c705,716
<     OSStatus status = OTCloseProvider((ProviderRef)mServiceRef);
<     CloseOpenTransport();           // should be moved to terminate routine
<     PRThread* dnsServiceThread;
<     rv = mThread->GetPRThread(&dnsServiceThread);
<     if (dnsServiceThread)
<         PR_Mac_PostAsyncNotify(dnsServiceThread);
<     rv = mThread->Join();
---
>     if (mServiceRef) {
> 	    OSStatus status = OTCloseProvider((ProviderRef)mServiceRef);
> 	}
> 	CloseOpenTransport();           // should be moved to terminate routine
> 	
> 	if (mThread) {
> 	    PRThread* dnsServiceThread;
> 	    rv = mThread->GetPRThread(&dnsServiceThread);
> 	    if (dnsServiceThread)
> 	        PR_Mac_PostAsyncNotify(dnsServiceThread);
> 	    rv = mThread->Join();
> 	}

If it still crashes, try moving the CloseOpenTransport() inside of the if-
statement with OTCloseProvider().

Status: NEW → ASSIGNED

Comment 14

18 years ago
Gordon-- I have tried your patch (both ways) and I do get further but I still 
crash.  Details in a minute or two...

Comment 15

18 years ago
after applying Gordon's proposed fix, I crashed in nsIOService::SetOffline, in 
the call to mDNSService->Shutdown.  I believe mDNSService is null.  Adding a 
check there (for mDNSService) got me still further but I still crash...

The next crash is in intl/uconv/nsURLProperties.cpp.  It seems that 
nsURLProperties(nsString&) wants the nsIIOService and isn't written to handle 
failure (it asserts but the code doesn't later check before it dereferences the 
service.  I haven't fixed this crasher yet but I doubt that nsURLProperties 
should require nsIIOService.  Hopefully cata will have some ideas before I get 
back to this bug.

Comment 16

18 years ago
Sorry, but I'm afraid that I can't help you: I've never touched that file. The 
latest changes are coming from putterman & warren. Adding ftang to the cc, as 
he's the original owner.
(Assignee)

Comment 17

18 years ago
I can fix the problem in nsDNSService and nsIOService.
Whiteboard: [PDT+] → [PDT+] 2/16/2000 (partial fix)
(Assignee)

Comment 18

18 years ago
nsDNSService and nsIOService have been fixed.  It looks like we need to fix intl/
uconv next.  Frank, who should look at it now?
Assignee: gordon → ftang
Status: ASSIGNED → NEW
Component: Networking → Internationalization

Comment 19

18 years ago
That code is done by warren (you should read cvsblame before decide who to
assign first) . Reassign to warren.
Assignee: ftang → warren
(Assignee)

Comment 20

18 years ago
Created attachment 5436 [details]
nsURLProperties.cpp with proposed change
(Assignee)

Comment 21

18 years ago
Kathy, can you verify my proposed change for this file, and see if it fixes the 
crash or just moves it further on. Thanks.
Assignee: warren → gordon
since about 2 days now, I can start offline without crashing!

Comment 23

18 years ago
2/16/2000 is over. Need new date.
Whiteboard: [PDT+] 2/16/2000 (partial fix) → [PDT+]

Comment 24

18 years ago
I downloaded and installed the 2000-02-21-18 nightly build of MozMacInstaller, 

and I'm still getting a crash without a net connection.  Has this fix made it 

through to the nightly builds yet? I would add a Stdlog, but Bugzilla ain't 

accepting them for some reason..

(Reporter)

Comment 25

18 years ago
Yep, still crashing. Not sure if fix has been checked in but, if it has, it
ain't workin'. MozMacM14 (2000022108) OS 9.
(Assignee)

Comment 26

18 years ago
We are no longer able to reproduce the crash.  We have fixed known problems with 
the shutdown of the DNS and IO services, so a stdlog of a current crash would be 
helpful.  Also, any addional info on machine type and system versions might help 
us reproduce the crash.
Status: NEW → ASSIGNED

Comment 27

18 years ago
Bugzilla ain't accepting attachments - it keeps complaining that the attachment 

was empty.  I'll email it directly to gordon.

(Reporter)

Comment 28

18 years ago
Alright, here it is in all its glory! StdLog from MacsBug 6.6. Crashes every single time startup w/o internet connection.  PowerMacintosh G4/450 
- First Release Nov. 99 :-( running OS 9 and oodles of software. Take away the SW, still crashes. Might want to move back from 
internationalization cause I run my Moz in English - you hear dat! (As you can see from my bug posting, I've been up for more than 24 hrs. & I 
just got back from rainy SF so I'm in a weird mood). If there's any info not included you think'd be helpful go ahead and comment it, I'll be sure to 
check my mail frequently and do my best to give you a satisfactory reply. (I will not, however, redownload the Moz source and try to build it 
again. Ugh!...) Sorry for the spam.
(Reporter)

Comment 29

18 years ago
Created attachment 5626 [details]
StdLog from MozMacM14 (2000022108) crash

Updated

18 years ago
Whiteboard: [PDT+] → [PDT+] Checking with chris on beta1 relnote
(Assignee)

Updated

18 years ago
Whiteboard: [PDT+] Checking with chris on beta1 relnote → [PDT+] Checking with chris on beta1 relnote, possible fix 2/24

Comment 30

18 years ago
If not fixed by 03/03, ok'd to relnote by chriss.  OS 9 only, yes?
Keywords: relnote
Whiteboard: [PDT+] Checking with chris on beta1 relnote, possible fix 2/24 → [PDT+] 03/03

Updated

18 years ago
Whiteboard: [PDT+] 03/03 → [PDT+] w/b minus on 03/03

Comment 31

18 years ago
No, I got the crash using OS 8.6.

(Assignee)

Comment 32

18 years ago
Okay, I've been able to reproduce this crash on a couple of Macs here.  With no
network connection, OTOpenInternetServices() sometimes fails, and sometimes
succeeds.  It seems to depend on whether the last used IP address was known to
be good.  I can fix the crashing bug in nsURLProperties.cpp.  Once that's done,
the behaviour changes to simply exiting mozilla if we are unable to create the
nsIOService.

We can limp along a bit further if I change the DNS service to delay calling
OTOpenInternetServices() until the first time an actual DNS lookup is
attempted.  That may allow us to bring mozilla up in offline mode.
(Assignee)

Comment 33

18 years ago
I've checked in code to prevent the crash, and I have additional code in my tree 
that allows us to continue working offline (I can browse file: urls even if 
OTOpenInternetServices fails).  I'm waiting for a review, and then I'll seek 
approval to check in.
(Assignee)

Comment 34

18 years ago
I've checked in a fix that enables offline mode for the Mac and allows browsing 
file: URLs even if OTOpenInternetServices() fails.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 35

18 years ago
Checked OS 8.6,  Kritzer checked OS 9.0
verified:  2000030108
Status: RESOLVED → VERIFIED

Comment 36

18 years ago
As the reporter of bug 25706, I can confirm that the bug is fixed on OS 8.6.  

Great job guys.

Updated

18 years ago
Blocks: 30247

Comment 37

16 years ago
- relnote 
changed summary for searchability.
Keywords: relnote
OS: All
Summary: Crash at start w/o internet connection → Conn: Crash at start w/o internet connection (MacOS only)
You need to log in before you can comment on or make changes to this bug.