Opening .eml file shows message source, rather than rendered message.

RESOLVED DUPLICATE of bug 241212

Status

RESOLVED DUPLICATE of bug 241212
14 years ago
11 years ago

People

(Reporter: serzholino, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

When opening saved messages in *.eml file format, there is no kind of parsing
them, justs message source, like in tird-party plain text editor/viewer. 


Reproducible: Always
Steps to Reproduce:
1.Fille/Open Saved Message
2.Open any *.eml file
3.
(Reporter)

Comment 1

14 years ago
And it would be very nice to have posibility to put this message into existing
message folder and to assign *.eml file type to Thunderbird. When i did it, then
doubleclick on this file just opens Thunderbird, or if it is already open, fires
opened window

Comment 2

14 years ago
Which TB version? It should work to display it, see Bug 217149.
(Reporter)

Comment 3

14 years ago
Thunderbird version 0.7.2 (20040707). It opens them, when File/Open Saved
Message, but Opened message looks like i view The sourse of the message, using
Ctrl+U. It's only in Win version. In Linux version it's ok. And Thunderbird
doesn't automaticallyassign *.eml files to itself, and even if i attached them,
it doesn't opens

Comment 4

14 years ago
Works for me in Thunderbird version 0.7.1 (20040626)

Comment 5

14 years ago
I don't see this with Win2K, but I do see it with Win98.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Bad opening *.eml files → Opening .eml file shows message source, rather than rendered message.

Comment 6

14 years ago
This bug is reproducable in Thunderbird v0.8 on WinXP Pro, and possibly on
Win2000Pro (will check).

Comment 7

14 years ago
I have seen slightly different behavior than described when opening a .eml file
previously saved from TB.

When it opens there is a message which is formatted to some extent, but is NOT
the same as when I opened the original message from within TB. Mainly, the
header fields are displayed IN the message body, and the attachment (which was
another email message) is not accessible at all. But the other text formatting
seems to be about right.

I will attach an image of the opened .eml file showing this.

This is TB version 0.8 (20040913).

Comment 8

14 years ago
Created attachment 159658 [details]
Screen shot of opened EML exhibiting described behavior

Comment 9

14 years ago
Created attachment 159659 [details]
Example EML exhibiting described behavior

Comment 10

14 years ago
David Hollman, that is the expected behavior.  What you want is bug 241212; see 
also bug 241213
Depends on: 269826
Blocks: 269826
No longer depends on: 269826

Comment 11

14 years ago

*** This bug has been marked as a duplicate of 241212 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 12

13 years ago
Altho the attachments to this bug did not exhibit the reported behavior -- 
completely plain-text display, which I *did* observe on a Win98 machine -- with 
TB 1.0.6 on Win98 (which does not have the patch from the purported dupe), I now 
see the message displayed as expected (that is, as shown in attachment 159659 [details]): 
partial header information shown as text but with a grey background.

However, with TB 1.0+0806 on Win98, the window for the EML file is all wrong -- 
see bug 241212 comment 21 & 22.
No longer blocks: 269826
You need to log in before you can comment on or make changes to this bug.