problems auto-starting firefox from a KDE "Save Session"

RESOLVED DUPLICATE of bug 93789

Status

()

Toolkit
Startup and Profile System
--
major
RESOLVED DUPLICATE of bug 93789
14 years ago
10 years ago

People

(Reporter: Landon Curt Noll, Assigned: Benjamin Smedberg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

A KDE "Save session" for a session in which firefox is running will not result
in firefox restarting when one logs in.  The same applies when the KDE
Session Manager is configured to "Restore previous session" / so-called
session auto-save mode.  In either case firefox does not restart after
a subsequent login.

If one configures the firefox launch icon to "Run in terminal" (a gross
configuration that requires a launch of an empty terminal window in addition
to the firefox window), KDE "Save Session" (and auto-save) will restart a
single firefox session after login (with that gross extra empty terminal
session), however it will NOT start a 2nd firefox window and the single
firefox browser will not restore the previous URL and tab state.

One can launch multiple firefox windows under KDE.  One cannot save their
state (URL and tab state) and recreate the KDE session in a subsequent login.

KDE is able to save and restart multiple KDE konqueror browser windows
with their current URLs and tab state saved.  One cannot do this for firefox.

I am using RHEL 3 with an up2date patched system and the current firefox
browser version.

Reproducible: Always
Steps to Reproduce:
Firefox fails to restart a single browser from a manually saved session
without a terminal window:

1.launch firefox from a KDE launch icon without "run in terminal" set
2.perform a "Save Session" when the KDE Component: Session Manager is in
  "Restore manually saved session" 
3.logout
4.login

Firefox fails to restart multiple browsers from a manually saved session without
a terminal window:

1.launch 2 or more firefox browsers from a KDE launch icon without "run
in terminal" set
2.perform a "Save Session" when the KDE Component: Session Manager is in
  "Restore manually saved session" 
3.logout
4.login

Firefox fails to restore a single browser from a manually saved session
with a terminal window:

1.launch firefox from a KDE launch icon WITH "run in terminal" set
2.perform a "Save Session" when the KDE Component: Session Manager is in
  "Restore manually saved session" 
3.logout
4.login

Firefox fails to restart multiple browsers from a manually saved session
with a terminal window:

1.launch 2 or more firefox browsers from a KDE launch icon WITH "run
in terminal" set
2.perform a "Save Session" when the KDE Component: Session Manager is in
  "Restore manually saved session" 
3.logout
4.login

NOTE: Selecting the KDE Compenet Session Manager mode of "Restore previous
session" (auto session save) does not change the firefox restart problem.

Actual Results:  
Firefox fails to restart a single browser from a manually saved session
without a terminal window:

no firefox windows are started

Firefox fails to restart multiple browsers from a manually saved session
without a terminal window:

no firefox windows are started

Firefox fails to restore a single browser from a manually saved session
with a terminal window:

An empty window is started, however firefox does not restart with the
previous URLs and tab state.

Firefox fails to restart multiple browsers from a manually saved session
with a terminal window:

An empty window is started, however firefox does not restart with the
previous URLs and tab state.  No other firefox browsers are restated.


Expected Results:  
In all cases all of the firefox browsers should restart in their exact
window position in their exact virtual desktops with their saved URL
and tab state restored.

Comment 1

14 years ago
Seamonkey can't do this either.

Comment 2

14 years ago
AFAIK this is a DUPlicate of bug 93789 ("Mozilla does not support the X11
session protocol") ... marking as such ...

*** This bug has been marked as a duplicate of 93789 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.