If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Find as you type thinks Microsoft Input Method Editor inputs is a link.

RESOLVED WORKSFORME

Status

()

Toolkit
Find Toolbar
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: Kenny Lee, Assigned: Blake Ross)

Tracking

unspecified
x86
Windows XP
Points:
---
Bug Flags:
blocking-aviary1.0PR -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040726 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040726 Firefox/0.9.1+

Creating a new blog entry (blogger.com). Using Input Method Editor to input
chinese characters. Firefox thinks Input Method Editor input is a link.

Reproducible: Always
Steps to Reproduce:
1.if you have a blog at www.blogger.com
2.click create a new post.
3.go to content area and start up Microsoft Input Method Editor(IME).
4.Input some characters using the Input Method Editor (I am using Chinese (PRC))
5.look at the bottom left corner of Firefox
6.Enter to confirm your input-ed characters.
7."Find as you type" will beeped as if you are searching for a link.

Actual Results:  
"Find as you type" will beeped as if you are looking for a link.

Expected Results:  
"Find as you type" should not beeped at all since you are inputing and not
searching for a link.
(Reporter)

Comment 1

13 years ago
Created attachment 154451 [details]
Screen Shot of bug
This is not only with that.

I start typing in an inputbox or a textbox and the "Find as you type" is beeped
too. Not only with Microsoft IME or things like that. I'm one Windows XP (french).

I don't know how to reprocuduce this bug, but I have to call the find function
manually to stop the find as you type.

I'll try to find more information about this bug... This is an important bug guys!

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040816
Firefox/0.9.1+
Flags: blocking-aviary1.0PR+

Comment 3

13 years ago
Only Firefox peers can + a blocking flag. The correct action is to request ?
blocking. and typically, a bug should be at least confirmed before you request it. 

Changing the + to ?
Flags: blocking-aviary1.0PR+ → blocking-aviary1.0PR?
Sorry, didn't know that.

Comment 5

13 years ago
Getting close to 1.0PR, I'm going to jump the gun here and help with triaging
the blocking nominations and say this isn't a blocker. Since there's no patch
and its not even confirmed.

If you'd like to request blocking 1.0 you're welcome to. Though I'd suggest
getting the bug confirmed first. :-)
Flags: blocking-aviary1.0PR? → blocking-aviary1.0PR-
Is this bug still happen? I think find toolbar doesn't have this problem.
If current build has this problem, this may be fixed by bug 55751.
Nobody replied to my comment.

-> WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.