add read status to Message Search results window

RESOLVED WORKSFORME

Status

enhancement
RESOLVED WORKSFORME
15 years ago
6 years ago

People

(Reporter: worcester12345, Unassigned)

Tracking

({polish})

17 Branch
x86
Windows 7
Bug Flags:
blocking-aviary1.0PR -
blocking-aviary1.0 -
blocking-aviary1.5 -
blocking-thunderbird2 -

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040725 Firefox/0.9.1+ (bangbang023)
Build Identifier: version 0.7 (20040617-pigfoot)

Details are in the "Steps to Reproduce".

Reproducible: Always
Steps to Reproduce:
1. Do a search on messages for some text in the body. This returns a list of
results.
2. Open one of the (unread) messages and read it.
3. Close message.
4. Attempt to mark message as unread once again.

Actual Results:  
Would not allow to mark as unread.

Expected Results:  
Should allow to mark as unread.

Has been doing this for several months and as many versions. BIG inconvenience
for me. Tried searching for this bug, but found none.
Reporter

Comment 1

15 years ago
This one still exists for the "official" version 0.7+ (20040803).

It has "Open" "File" "Delete" and "Open Message Folder" buttons along the
bottom, but no "Mark" buttons. No little green "read/unread" button in the email
either.

Thanks.
Reporter

Comment 2

15 years ago
Still there: version 0.7+ (20040817)

Comment 3

15 years ago
i can confirm it in thunderbird branch 0.7+ (20040822)

would rather have the context menu upon right-click
Reporter

Updated

15 years ago
Flags: blocking-aviary1.0?
Reporter

Updated

15 years ago
Flags: blocking-aviary1.0PR?

Comment 4

15 years ago
minusing
Flags: blocking-aviary1.0PR?
Flags: blocking-aviary1.0PR-
Flags: blocking-aviary1.0?
Flags: blocking-aviary1.0-
Reporter

Comment 5

15 years ago
Is this one at all related? They both have to do with usefulness in the mail
front end.

https://bugzilla.mozilla.org/show_bug.cgi?id=101153 Search messages window has
no intrinsic way of closing itself.

Should this be changed from Thunderbird to Mailnews?

Reporter

Comment 6

15 years ago
Can we set a target milestone for this bug to either Thunderbird0.8 or 0.9? I'd
like to see SOME milestone set, so this gets addressed. 

Thanks.
Reporter

Comment 7

15 years ago
Can someone please confirm this bug?
Reporter

Updated

15 years ago
Keywords: helpwanted
Summary: cannot mark mail as unread after opening from search window → can't mark mail as unread after viewing it in search window

Comment 8

15 years ago
changed summary and severity to reflect what I think reporter is asking for...
Severity: major → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: can't mark mail as unread after viewing it in search window → add message read column to search results window
Reporter

Comment 9

15 years ago
I think my original description was more accurate, but I'll leave yours to see
if it makes more sense to someone. It IS a bug, though, as it changes one's
message and does not let one change it back to unread afterwards. If one cannot
change it back themselves, maybe the software shouldn't mark it as read to begin
with. This whole interface needs some work, but all I want is the ability to put
messages back to the status they were in before searching for them.
Severity: enhancement → normal

Comment 10

15 years ago
your description was very specific about what you wanted to do, but the actual
problem is much more general - you can't change the read status (to either read
*or* unread) from the search results window...independent of whether you've read
the message in a stand-alone msg window, etc.
Reporter

Comment 11

15 years ago
Can we get a target milestone here? Thanks. Even as "bug owner", it won't let me
change or add this.
Reporter

Updated

15 years ago
Flags: blocking-aviary1.1?

Updated

15 years ago
Flags: blocking-aviary1.1? → blocking-aviary1.1-
Reporter

Comment 12

15 years ago
(In reply to comment #10)
> your description was very specific about what you wanted to do, but the actual
> problem is much more general - you can't change the read status (to either read
> *or* unread) from the search results window...independent of whether you've read
> the message in a stand-alone msg window, etc.

Correct. I see some work was done on search recently (Bug 278932), so hopefully
some of the other search functions will be looked at soon.
Reporter

Comment 13

14 years ago
I guess by unblocking, you have no intention of doing this before 1.1 then. A
real bummer.
Reporter

Comment 14

14 years ago
Also add "junk status" change button.

I was searching for, and found several messages but could not control click them
to mark as junk from search window.

Thanks.
Summary: add message read column to search results window → add message read , junk status to search results window
Reporter

Comment 15

14 years ago
I hate to be a pain, and know this is not 100% proper, but I'd like to just keep
this on the radar since search bugs were currently being worked on. Sorry and
thanks.
Reporter

Updated

14 years ago
Flags: blocking-aviary2.0?
Reporter

Comment 16

14 years ago
Any other operating systems seeing this?
Reporter

Updated

14 years ago
Assignee: mscott → nobody
Reporter

Updated

14 years ago
Keywords: mail6
Flags: blocking-firefox2? → blocking-thunderbird2?

Updated

14 years ago
Flags: blocking-thunderbird2? → blocking-thunderbird2-
Reporter

Updated

13 years ago
Keywords: polish
Reporter

Comment 17

13 years ago
Since some of the junk controls are now being worked on, maybe this could be fixed now as well.
Flags: blocking-thunderbird2- → blocking-thunderbird2?
Reporter

Comment 18

13 years ago
Any search fixes going in before the 2.0 freeze which this could possibly piggyback in on?

Comment 19

13 years ago
minusing. no one's volunteered and we probably won't get to this for 2.
Flags: blocking-thunderbird2? → blocking-thunderbird2-
Reporter

Comment 20

13 years ago
Any way we can get this little bugaboo fixed or at least put in ability to block Thunderbird 3 or 4?
Reporter

Comment 21

12 years ago
Please at least add it to the Thunderbird 3 milestone. Thank you.
QA Contact: front-end
Reporter

Updated

12 years ago
Flags: blocking-thunderbird3?
Please don't abuse blocking flags by using them on any bug that you want someone else to fix for you. A blocker is a bug that we absolutely would not ship that release without fixing. The fact that we were willing to ship 1.0, and 1.5, and 2.0 without fixing this should serve as a very, very strong hint that if nobody volunteers to fix it, we will be willing to ship 3.0 without it, too.
Flags: blocking-thunderbird3?
Reporter

Comment 23

12 years ago
This is such a minor issue, and version 3 is so far off, where else would one put it to block? There are no version 4 blocking flags yet. 
If you don't understand that there are bugs which, though we would like to have them fixed, should not ever be marked as blocking any release, you don't understand blocking flags at all. Please just don't use them at all, on any bugs.
Worcester12345, "unread" status is available from column picker. are you looking to change the status from the results window?

Note: I'm not aware any columns allow changing the value from results list.

narrowing to one issue (one issue per bug please)
Severity: normal → enhancement
Summary: add message read , junk status to search results window → add read status to Message Search results window
You can change the read status from the result window, by clicking the green "unread" column icon.
Keywords: helpwanted
Reporter

Updated

10 years ago
Version: unspecified → 2.0
Reporter

Comment 27

10 years ago
Can we request this for 3.1?
(In reply to comment #27)
> Can we request this for 3.1?
We'd need a patch in order to be able to request it and make sure it goes in.
Reporter

Comment 29

9 years ago
(In reply to comment #10)
> your description was very specific about what you wanted to do, but the actual
> problem is much more general - you can't change the read status (to either read
> *or* unread) from the search results window...independent of whether you've read
> the message in a stand-alone msg window, etc.

This is still a problem in this version:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.10) Gecko/20100518 Shredder/3.0.6pre
Version: 2.0 → 3.0
Reporter

Comment 30

8 years ago
I am actually seeing the ability to right click and add the "green dot" in the search results window now. While it has no explanation, and is non-intuitive, it is close to being an answer to this bug.
Reporter

Updated

8 years ago
Version: 3.0 → 3.1
Reporter

Comment 31

8 years ago
Absent any further work on this bug, I think I'll just leave it at WONTFIX, since it is fixable, but nobody wants to add the "Mark as Unread" to a context menu. Thanks anyhow.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
I would certainly not not fix this, so WONTFIX isn't really the right resolution.  Heck, if you have a patch I'll be happy to review it!  (I'm afraid there are some other, higher-priority, things that I'm working on, so I can't write the code myself.)

Thanks,
Blake.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Reporter

Updated

6 years ago
Version: 3.1 → 17
Reporter

Updated

6 years ago
OS: Windows XP → Windows 7
Reporter

Comment 33

6 years ago
This bug is almost 9 years old now. I don't really care about it any more, and it seems nobody else does either. I'm going back to "WONTFIX" status.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago6 years ago
Resolution: --- → WONTFIX
Actually this is wfm, per previous comments. (You can click on the "read" indicator in to toggle read state)
Resolution: WONTFIX → WORKSFORME
You need to log in before you can comment on or make changes to this bug.