data: cannot use HTTP redirecting

VERIFIED DUPLICATE of bug 211999

Status

()

defect
--
minor
VERIFIED DUPLICATE of bug 211999
15 years ago
15 years ago

People

(Reporter: bugzilla, Assigned: darin.moz)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040514
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040514

<http://tinyurl.com/4qfzh> redirects you to
<http://unicyclist.com/tinyurl/redirect.php?num=4qfzh>.  Then
<http://unicyclist.com/tinyurl/redirect.php?num=4qfzh> redirects you to a data
URI.  Even though Mozilla supports data URI's, the browser does not take you
there.  Instead the HTML page at
<http://unicyclist.com/tinyurl/redirect.php?num=4qfzh> is rendered.

Reproducible: Always
Steps to Reproduce:
1. goto <http://tinyurl.com/4qfzh>

Actual Results:  
Shows the HTML respose of <http://unicyclist.com/tinyurl/redirect.php?num=4qfzh>

Expected Results:  
Taken me to
<data:text/plain;charset=utf-8;base64,bW9kdWxlIFN0cmVhbU1vbmFkIHdoZXJlDQoNCmltcG9ydCBEYXRhLkFycmF5LklBcnJheQ0KaW1wb3J0IENvbnRyb2wuTW9uYWQuU3RhdGUNCg0KY2xhc3MgKE1vbmFkIG0pID0%2BIChNb25hZFN0cmVhbSBhIG0pIHwgbSAtPiBhIHdoZXJlDQogICBuZXh0IDo6IG0gYQ0KICAgZW5kT2ZTdHJlYW0gOjogbSBCb29sDQoNCmluc3RhbmNlIChJQXJyYXkgYSBlLCBOdW0gaSwgSXggaSkgPT4gTW9uYWRTdHJlYW0gZSAoU3RhdGUgKChhIGkgZSksIGkpKSB3aGVyZQ0KICAgbmV4dCA9IGRvIChhcnIsIGluZGV4KSA8LSBnZXQNCiAgICAgICAgICAgICBwdXQgKGFyciwgaW5kZXgrMSkNCiAgICAgICAgICAgICByZXR1cm4gKGFyciFpbmRleCkNCiAgIGVuZE9mU3RyZWFtID0gZG8gKGFyciwgaW5kZXgpIDwtIGdldA0KICAgICAgICAgICAgICAgICAgICByZXR1cm4gJCBub3QgJCBpblJhbmdlIChib3VuZHMgYXJyKSBpbmRleA0KDQppbnN0YW5jZSAoSUFycmF5IGEgZSwgTnVtIGksIEl4IGkpID0%2BIE1vbmFkU3RyZWFtIGUgKFN0YXRlICgoYSBpIGUpLCBpKSkgd2hlcmUNCiAgIG5leHQgPSBkbyAoYXJyLCBpbmRleCkgPC0gZ2V0DQogICAgICAgICAgICAgcHV0IChhcnIsIGluZGV4KzEpDQogICAgICAgICAgICAgcmV0dXJuIChhcnIhaW5kZXgpDQogICBlbmRPZlN0cmVhbSA9IGRvIChhcnIsIGluZGV4KSA8LSBnZXQNCiAgICAgICAgICAgICAgICAgICAgcmV0dXJuICQgbm90ICQgaW5SYW5nZSAoYm91bmRzIGFycikgaW5kZXgNCg%3D%3D>

Work around:
In this case, the user can still cut and paste the URI into the location bar.

*** This bug has been marked as a duplicate of 211999 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
V/dupe
Status: RESOLVED → VERIFIED
Summary: HTTP redirecting to data URI's do not work. → data: cannot use HTTP redirecting
You need to log in before you can comment on or make changes to this bug.