Firefox update fails to display "check for updates" results

RESOLVED DUPLICATE of bug 251931

Status

()

Toolkit
Application Update
--
major
RESOLVED DUPLICATE of bug 251931
14 years ago
9 years ago

People

(Reporter: Hussam Al-Tayeb, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040727 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040727 Firefox/0.9.1+

Open firefox and check for updates. If no updates are found, you won't get a
message that no updates are found. Instead, firefox will generate this JS error
Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://mozapps/content/update/update.js :: anonymous :: line 423"  data: no]

Reproducible: Always
Steps to Reproduce:
1.open firefox.
2.check for updates

Actual Results:  
the check for updates dialog opened but failed to give the results or display a
message that no updates were found

Expected Results:  
The software should have displayed a messeage that no updates were found.
Also, this error was in the JS console
Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://mozapps/content/update/update.js :: anonymous :: line 423"  data: no]
(Reporter)

Updated

14 years ago
Flags: blocking-aviary1.0PR?
Flags: blocking-aviary1.0?
(Reporter)

Updated

14 years ago
Summary: Firefox update fails to display "no updates found" message → Firefox update fails to display "check for updates" results

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 251931 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Flags: blocking-aviary1.0PR?
Flags: blocking-aviary1.0?
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.