opening a "mailto:xxx@xxxx.xxx" link with CTRL key pressed (4 new tab) it opens an empty tab and then the "Mail Client".

RESOLVED DUPLICATE of bug 97032

Status

()

Firefox
Tabbed Browser
--
trivial
RESOLVED DUPLICATE of bug 97032
14 years ago
14 years ago

People

(Reporter: Ignacio Martínez, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Fireycd/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

When hitting any mailto: anchor with the CTRL key pressed (for new tab)
the browser opens a new tab, and then the Mail Client comes on top.
The new tab stays in the background (as espected)
The tab title (on the tab itself) reads the anchor url: "mailto:whatever@it.is"
The browser title (when *this* tab is selected) is just the browser name
There is no tab content (just a gray tab, no canvas at all)



Reproducible: Always
Steps to Reproduce:
1.go to any url with a mailto anchor
2.press the CONTROL key
3.click on the link


Actual Results:  
As said before a new tab its open in the background (as espected if it
were a standar link instead of a mailto: link)

Expected Results:  
i'm not sure. but it is my feeling this is not the expected behaivior for 
average user (nor for me). I did not expect this new tab to open at all.

Comment 1

14 years ago
Does this dup to the Seamonkey bug 97032?
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> Does this dup to the Seamonkey bug 97032?

yeah. it seems the same... i didn't find that one (sorry about that)
as i didn't think it could happen the same with new windows 
(using SHIFT instead) as it does. 

should'nt the browser check the protocol before it does open a new tab.. 
and if the protocol is supported via another app, just let it go?

(Reporter)

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 97032 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.