Bookmarks lost when Mozilla not open and Windows internet properties is used to delete all offline content

RESOLVED INVALID

Status

--
critical
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: leavens, Assigned: p_ch)

Tracking

1.7 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707

I lose my Mozilla bookmarks each time I have Mozilla closed and use the Windows
Internet Options to delete temporary internet files, and check on "delete all
offline content".

Reproducible: Always
Steps to Reproduce:
0. Save your mozilla bookmarks in a file (optional but helpful).
1. Observe that you have bookmarks in Mozilla.
2. Close Mozilla (exit the program).
3. Open Internet Explorer and go to the Tools/Internet Options menu item, or use
the Internet Options on the control panel, and select from the middle pane on
the default tab that appears "Delete Files...".
4. From the popup, check the box marked "Delete all offline content", and click
on Ok.
5. Start Mozilla, observe that all bookmarks are gone. 

Actual Results:  
Using Windows' internet properties should not delete Mozilla's bookmarks.

Expected Results:  
Probably stored the bookmarks somewhere where Windows couldn't delete them
accidently.
(Reporter)

Comment 1

14 years ago
I'm sorry, but while I can reproduce this reliably on my home Windows machine, I
can't do so from my notebook computer.  Both are running Windows XP
Professional.  I only have one user account that I use on the home computer
where the problem I described does happen reliably.  But on my notebook computer
I have 2.  Perhaps this is related to the problem?

Comment 2

14 years ago
What is the full path of your bookmarks.html file?
(Reporter)

Comment 3

14 years ago
On the machine that does *not* demonstrate the problem, (just because that's 
where I am now, for comparison purposes, the bookmarks seem to be in the 
following file:

C:\Documents and Settings\leavens.COMS.000\Application 
Data\Mozilla\Profiles\Default User\4gnr6c7g.slt\bookmarks.html

I'll let you know where the bookmarks are stored are on the machine that does 
have this problem later today.  Is there a way to find this location from 
within mozilla?

Comment 4

14 years ago
(In reply to comment #3)
> I'll let you know where the bookmarks are stored are on the machine that does 
> have this problem later today.  Is there a way to find this location from 
> within mozilla?

AFAIK no. But normally it should be in your Mozilla user profile.

Comment 5

14 years ago
In Bookmark Manager ( Bookmarks->Manage Bookmarks, or Ctrl+B) you can export
your Bookmarksfile to save a copy, and you can open another bookmarks file,
replacing the current one, located somewhere, doesn´t have to be in the profile
folder, doesn´t have to have the name bookmarks.html.
In about:config you can see the path to your bookmarks file, if you ever changed it.
browser.bookmarks.file    user set   string   E:\somePath\bookmark\bookmark.htm

in Bookmark Manager:
Tools->Export
File->Open Bookmarks File

If you want to know more about the profile:
http://kb.mozillazine.org/index.phtml?title=Profile_Folder
(Reporter)

Comment 6

14 years ago
My bookmarks on the computer that shows the problem seem to be in

C:\Documents and Settings\leavens\Application 
Data\Mozilla\Profiles\default\rxuyper0.slt\bookmarks.html
(Reporter)

Comment 7

14 years ago
Our updates crossed.  Here's the value, on my machine that has the problem of 
the browser.bookmarks.file property from the about:config window:

C:\Documents and Settings\leavens\Local Settings\Temporary Internet 
Files\Content.IE5\8DARKL23\index[1].html

That, surely is the problem, as it's not located where I thought it was.

While it's nice to know that I can fix this (and I will), I never before knew 
about the about:config page and didn't set this value myself.  I guess this 
happened because of some version of Mozilla I installed.  Or perhaps when I 
imported bookmarks, it did that?  So from your point of view, the problem then 
becomes: is it possible that the installation or bookmark import procedures 
can set the bookmark file to such a value?

Comment 8

14 years ago
Import Bookmarks should not change the location, but Open Bookmarks File does, I
guess. So this bug is INVALID?
Product: Browser → Seamonkey

Comment 9

14 years ago
You changed the location of the bookmarks file to the IE cache (see comment 7).
So delete all offline content will erase it. Change the location back (use the
pref) and copy the file.

Marking INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Version: Trunk → 1.7 Branch
You need to log in before you can comment on or make changes to this bug.