Back Button "forgets" where you were on a long page.

RESOLVED DUPLICATE of bug 217120

Status

()

RESOLVED DUPLICATE of bug 217120
15 years ago
12 years ago

People

(Reporter: mrbill, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DUPEME], URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.8

the url is just one example. This happens on eBay all the time, too, and it does
not happen with IE.

If I am in the middle of a long page and click a link, the click on another link
on the new page, then backup two pages to the original long page I was on, I
wind up at the top of the page about 80% of the time. (The example I used is a
good one as it is very long and most of the listings you can drill down two
levels from the first page).

This is quite annoying in such websites as eBay, etc., and should be an easy fix.

Reproducible: Always
Steps to Reproduce:
Follow these specific steps, please. . .
1. Browse to http://www.loveme.com/women/update.htm
2. Scroll down a couple screens to, say to "62983 Nataly".
3. Click on the text beginning with "62983 Nataly".
4. This takes you to Nataly's profile.
5. Scroll down to the bottom and click on link "Click here for additional photos
of Nataly 62983".
6. This takes you to a page of additional pictures (duh?) Scroll down a bit.
7. Click the back arrow twice to go back to the original page. . .
8. Voila, you're at the top of the page instead of the page with Nataly's
thumbnail picture. 
9. Oddly enough, this happens only about 80% of the timer so (just a guess. .
.it usually happens this way).

Actual Results:  
You do not return to the spot on the original page where you left. You return to
the top of the page instead of to the location on the page where you left via
clicking a link.

Expected Results:  
Firefox .9.2, which I'm using, should have gone back to the same spot on the
page where I originally left that page.

Comment 1

15 years ago
Clicking "Back" often takes me to the top of the previous page instead of the
point where I left it.  Would like the browser to recall position on page where
I left.

Comment 2

15 years ago
I also see this problem and can attest to how irritating it is. Oddly enough,
I'm pretty sure I saw it a long time ago, then it went away, then it came back
with version 1.7 (.0 and .2, never used .1). And unlike the original poster, I
see it after just one click forward and one back.

This is one page I see it on on a daily basis:

http://www.craigslist.org/sfc/mis/

I am using Mozilla 1.7.2:

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.2) Gecko/20040803

Updated

14 years ago
Whiteboard: [DUPEME]

Comment 3

14 years ago
I notice that Firefox does this ONLY if the Render Mode is "Standards compliance
mode" (Right-click on page->View Page Info) If you browse a website that is
rendered in "Quirks mode" (like Bugzilla) then Firefox will NOT forget page
location.

Thanks,
    - Andrei

Comment 4

14 years ago
Bug 217120 is almost identical to this bug.  Including it's relevence to ebay.com. 

*** This bug has been marked as a duplicate of 217120 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.