Problems with threaded mail view

VERIFIED FIXED in M14

Status

MailNews Core
Backend
P3
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: scottputterman, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] ETA 01/28)

(Reporter)

Description

19 years ago
I've been having a bunch of problems with threads in my IMAP Inbox.  First, 
whenever I thread it, I get the assertion listed below where there's aparently 
no root hdr.  Then, not all of my messages always show up in threaded mode. This 
seems to degrade over time.  I've deleted .msf files but these problems come 
back.  've had situations where a thread says it has 3 messages but only shows 
two. Deleting the .msf file makes it work, but over time these problems come 
back.  I'm also seeing this in newsgroups.  I'm seeing some unread totals going 
to -1.

NTDLL! 77f7629c()
nsDebug::Assertion(const char * 0x03d9af70, const char * 0x03d9af50, const char 
* 0x03d9af18, int 726) line 189 + 13 bytes
nsMsgThreadEnumerator::Prefetch() line 726 + 65 bytes
nsMsgThreadEnumerator::HasMoreElements(nsMsgThreadEnumerator * const 0x044aa980, 
int * 0x0012bd64) line 785
nsMessageFromMsgHdrEnumerator::HasMoreElements(nsMessageFromMsgHdrEnumerator * 
const 0x044acd00, int * 0x0012bd64) line 187
nsMessageViewThreadEnumerator::HasMoreElements(nsMessageViewThreadEnumerator * 
const 0x05748f70, int * 0x0012bd64) line 754 + 30 bytes
CompositeEnumeratorImpl::HasMoreElements(CompositeEnumeratorImpl * const 
0x057489b0, int * 0x0012be0c) line 228 + 22 bytes
RDFGenericBuilderImpl::CreateContainerContents(nsIContent * 0x0354e820, 
nsIRDFResource * 0x021da770, int 0, nsIContent * * 0x0012bf88) line 2485 + 36 
bytes
RDFGenericBuilderImpl::CreateTemplateAndContainerContents(nsIContent * 
0x0354e820, nsIContent * * 0x0012bf88) line 2383 + 30 bytes
RDFGenericBuilderImpl::RebuildContainer(RDFGenericBuilderImpl * const 
0x035569c0, nsIContent * 0x0354e820) line 888 + 36 bytes
nsXULDocument::RebuildWidgetItem(nsIContent * 0x0354e820) line 3929 + 22 bytes
nsXULDocument::AttributeChanged(nsXULDocument * const 0x0334e530, nsIContent * 
0x0354e820, int 0, nsIAtom * 0x02519470 {"ref"}, int -1) line 1425
nsXULElement::SetAttribute(nsXULElement * const 0x0354e820, int 0, nsIAtom * 
0x02519470 {"ref"}, const nsString & {"imap://scottip@nsmail-2.mcom.com/INBOX"}, 
int 1) line 2452
nsXULElement::SetAttribute(nsXULElement * const 0x0354e834, const nsString & 
{"ref"}, const nsString & {"imap://scottip@nsmail-2.mcom.com/INBOX"}) line 1165 
+ 35 bytes
nsXULTreeElement::SetAttribute(nsXULTreeElement * const 0x037fa998, const 
nsString & {"ref"}, const nsString & {"imap://scottip@nsmail-2.mcom.com/INBOX"}) 
line 51 + 29 bytes
ElementSetAttribute(JSContext * 0x03326470, JSObject * 0x02bf3bd8, unsigned int 
2, long * 0x03a18008, long * 0x0012c684) line 263 + 26 bytes
js_Invoke(JSContext * 0x03326470, unsigned int 2, unsigned int 0) line 666 + 26 
bytes
js_Interpret(JSContext * 0x03326470, long * 0x0012cf00) line 2262 + 15 bytes
js_Invoke(JSContext * 0x03326470, unsigned int 4, unsigned int 0) line 682 + 13 
bytes
js_Interpret(JSContext * 0x03326470, long * 0x0012d738) line 2262 + 15 bytes
js_Invoke(JSContext * 0x03326470, unsigned int 3, unsigned int 0) line 682 + 13 
bytes
js_Interpret(JSContext * 0x03326470, long * 0x0012df70) line 2262 + 15 bytes
js_Invoke(JSContext * 0x03326470, unsigned int 1, unsigned int 0) line 682 + 13 
bytes
js_Interpret(JSContext * 0x03326470, long * 0x0012e7a8) line 2262 + 15 bytes
js_Invoke(JSContext * 0x03326470, unsigned int 0, unsigned int 0) line 682 + 13 
bytes
js_Interpret(JSContext * 0x03326470, long * 0x0012efe0) line 2262 + 15 bytes
js_Invoke(JSContext * 0x03326470, unsigned int 1, unsigned int 2) line 682 + 13 
bytes
js_InternalInvoke(JSContext * 0x03326470, JSObject * 0x02bf3c78, long 46091120, 
unsigned int 0, unsigned int 1, long * 0x0012f168, long * 0x0012f114) line 759 + 
19 bytes
JS_CallFunctionValue(JSContext * 0x03326470, JSObject * 0x02bf3c78, long 
46091120, unsigned int 1, long * 0x0012f168, long * 0x0012f114) line 2771 + 31 
bytes
nsJSContext::CallEventHandler(nsJSContext * const 0x03326600, void * 0x02bf3c78, 
void * 0x02bf4b70, unsigned int 1, void * 0x0012f168, int * 0x0012f164) line 562 
+ 33 bytes
nsJSEventListener::HandleEvent(nsIDOMEvent * 0x05765414) line 128 + 57 bytes
(Assignee)

Comment 1

19 years ago
marking beta1,dogfood, and accepting. Don't know what could be causing this. I 
haven't changed any threading code that I can remember.
Status: NEW → ASSIGNED
Keywords: beta1, dogfood
Target Milestone: M14

Comment 2

19 years ago
Putting on PDT+ radar for beta1.
Whiteboard: [PDT+]

Comment 3

19 years ago
resummarized so we don't get hit with nspr thread queries :-)
Summary: Problems with threads → Problems with threaded mail view
(Assignee)

Comment 4

19 years ago
I see this assert in a folder with a brand new .msf file, so deleting is not 
required to make this happen. Somehow a thread is empty, which causes an error 
which propagates all the way up to rdf.
Whiteboard: [PDT+] → [PDT+] ETA 02/03
(Assignee)

Comment 5

19 years ago
OK, I'm an idiot. I'll check in a fix when the tree opens.
Whiteboard: [PDT+] ETA 02/03 → [PDT+] ETA 01/28
(Assignee)

Comment 6

19 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 7

19 years ago
Great, thanks for fixing this.  Pulling the fix now..
(Assignee)

Comment 8

19 years ago
Oh, you will need to delete the affected .msf files.
(Reporter)

Comment 9

19 years ago
*** Bug 25047 has been marked as a duplicate of this bug. ***

Updated

19 years ago
QA Contact: lchiang → fenella

Comment 10

19 years ago
Win32 (2000-02-02-09 M14)
The thread view looks OK. 

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 11

19 years ago
Mac (2000-02-11-12 M14)
Win32 (2000-02-11-09 M14)
Linux (2000-02-11-11 M14)
I do not see any problem with threaded view.  The problem has been fixed.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.