If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Can't open pop connection because mail username contains "."

RESOLVED WORKSFORME

Status

MailNews Core
Networking: POP
--
major
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: Stephane Le Roux, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.1) Gecko/20040707
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.1) Gecko/20040707

I have setup 2 mail accounts :
1- username=leroux@eaysnet.fr
2- username=stef.lrx@neuf.fr

Steps to reproduce
- When I want to retrieve messages mozilla ask for password
- fulfill password account 1 --> got the mails :OK
- fulfill for account 2 --> error in username or password??
- ask mozilla to memorize the username and password
- go in password manager, show password --> password is OK but username has
change : the character "." has been replaced by "%2E"

My conclusion : when username includes "." character send mozilla translate and
pop connection fails

Reproducible: Always
Steps to Reproduce:
- When I want to retrieve messages mozilla ask for password
- fulfill password for account leroux@easynet.fr --> got the mails :OK
- fulfill password for account stef.lrx@neuf.fr --> error in username or password??
- ask mozilla to memorize the username and password
- go in password manager, show password --> password is OK but username has
change : the character "." has been replaced by "%2E"

Actual Results:  
pop connection failed because of "." character in mail

Expected Results:  
connect to pop server

My conclusion : when username includes "." character send mozilla translate and
pop connection fails

Comment 1

13 years ago
Yes, in the password manager some characters are escaped.
But for sending the username a) escaped passwords are unescaped and b) the user
name to be sent is taken from userName resp. realuserName in the prefs.js and
thus also unescaped.

So the problem must be something else.
To test what's really sent you could log the communication with an external
logger like windump or Ethereal.
To log at least the username you could also set mail.server.default.auth_login
in the prefs.js to false (set it back to true after testing) and create a
mozilla log as explained at
http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#pop.

Some feedback would be nice.

Comment 2

13 years ago
Another user with the same problem in thread:
http://forums.mozillazine.org/viewtopic.php?p=965422#965422

(And there is a log in the thread.)
Product: MailNews → Core
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Unless a code change or duplicate bug can be identified, this should be marked WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WORKSFORME
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.