If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

New Feature: Add "Delete" and "Move Up/Down" buttons to Filter Rules dialog

VERIFIED WORKSFORME

Status

Thunderbird
Mail Window Front End
--
enhancement
VERIFIED WORKSFORME
13 years ago
10 years ago

People

(Reporter: Doug Hockin, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

The Message filters dialog only allows deleting a filter by clicking
"Fewer" which deletes off the bottom of the list.  One should be able to
select any filter and delete it with a Delete button or Backspace,
Delete or Ctrl-x keys.

One should be able rearrange the order of filters with a Move Up/Down
button pair.


Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

13 years ago
(In reply to comment #0)
> The Message filters dialog only allows deleting a filter by clicking
> "Fewer" which deletes off the bottom of the list.  One should be able to
> select any filter

That is, "... any match criterion..."

> and delete it with a Delete button or Backspace, Delete or Ctrl-x keys.

This is a good idea; I think it may be a dupe, but I can't find the other bug.


> One should be able rearrange the order of filters with a Move Up/Down
> button pair.

This is not necessary for the correct operation of the filter, but could be nice 
for organizing the criteria in case the filter is complex and needs frequent 
tweaking.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: New Feature: Add "Delete" and "Move Up/Down" buttons to Message Filters dialog → New Feature: Add "Delete" and "Move Up/Down" buttons to Filter Rules dialog

Comment 2

13 years ago
*** Bug 272962 has been marked as a duplicate of this bug. ***

Comment 3

13 years ago
(In reply to comment #1)
> This is a good idea; I think it may be a dupe, but I can't find the other bug.

Bug 87547 is listed as a "Core/Mailnews:Filters" bug, altho it looks to me more 
like a front-end issue than a true Filters issue.

Comment 4

13 years ago
*** Bug 275989 has been marked as a duplicate of this bug. ***

Comment 5

13 years ago
xref bug 195224 -- the fix for that does, at least, provide a way of deleting a 
criterion from the middle of the list.

(Also note, viz. comment 3: that bug was filed under Core::MailNews:Filters, but 
the fix applies to both the suite and TB.)

Comment 6

12 years ago
While this is pretty powerfull, it would really get powerfull if it would also
give the user options to use and / or switches just like the keyword filter
options found in applications like greentides.net

This would give the user the power to build complex trees of filter rules.

I think the default behaviour today is OR, since every filter statement works on
it own. But this really doesn't give the user much power.

Comment 7

12 years ago
(In reply to comment #6)
> While this is pretty powerfull, it would really get powerfull if it would also
> give the user options to use and / or switches just like the keyword filter
> options found in applications like greentides.net
> 
> This would give the user the power to build complex trees of filter rules.

That's bug 297852.  Please do not post comments in bugs that are unrelated to 
the actual problem of the bug.  Learn how to search the bug database, and open a 
*new* bug for a new issue if you can't find an exact match.
QA Contact: front-end

Comment 8

10 years ago
On Mac trunk I have all 3 of the requested buttons.  I'm marking this as WFM, but reopen if I've missed some aspect of this enhancement that hasn't yet been implemented.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Comment 9

10 years ago
VERIFIED on Win32 Thunderbird v2.0.0.12 (20080213)

Both Message Filters and Filter Rules dialogs are now usable and allow insertion/deletion of filters or rules.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.