Find in this Page on a <frameset> page should start in the <frame> that was last clicked

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
14 years ago
3 years ago

People

(Reporter: L.Wood, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: bugday0420, URL)

(Reporter)

Description

14 years ago
Even when an individual frame in a frame page is clicked on:

Find in this Page... Ctrl+F
only searches and highlights text in the first frame of the last frameset specified.

Find Text as you Type /
only searches and highlights text in the first frame in the last frameset specified.

The right-click context menu has a 'This Frame' submenu, but no Find option on
that menu.

It would be reasonable to expect the Edit menu 'Find in this Page...' to alter
to 'Find in this Frame' on a framed page - Frame matches Ctrl+F better.
Product: Browser → Seamonkey

Comment 1

14 years ago
I have the same problem too.  When I am in some site with frames (like J2EE
API), FireFox fail to find text base on neither the location of my cursor, nor
the page of where I last clicked.  The version info is as followed:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Comment 2

10 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED
moving to Core::Layout:HTML_Frames, feel free to reassign or resolve as appropriate
Assignee: general → nobody
Component: General → Layout: HTML Frames
Product: SeaMonkey → Core
QA Contact: general → layout.html-frames
Whiteboard: bugday0420
Version: Trunk → unspecified

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: x86 → All

Updated

7 years ago
Component: Layout: HTML Frames → Find Toolbar
Product: Core → Toolkit
QA Contact: layout.html-frames → fast.find
Summary: Can't find text in frame → Find in this Page on a <frameset> page should start in the <frame> that was last clicked

Updated

7 years ago
Duplicate of this bug: 362588

Updated

7 years ago
Duplicate of this bug: 407338

Updated

7 years ago
Duplicate of this bug: 714053
Since this looks like a rather niche enhancement and framesets being less popular nowadays, I don't think we'll be implementing this.
Please feel free to reopen if you think this bug was closed in error.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX

Comment 8

3 years ago
FYI, Chrome fixed this issue years ago. Millions of Java developers appreciated the fix.
(In reply to Gili from comment #8)
> FYI, Chrome fixed this issue years ago. Millions of Java developers
> appreciated the fix.

Don't get me wrong, I'd love to see this fixed as well! We just don't have the resources available to work on this, I'm afraid.
You need to log in before you can comment on or make changes to this bug.