Find in page with new search toolbar does not work when some ads are blocked

VERIFIED FIXED

Status

()

P3
normal
VERIFIED FIXED
15 years ago
11 years ago

People

(Reporter: Athropos, Assigned: bugzilla)

Tracking

({fixed-aviary1.0})

unspecified
x86
Windows XP
fixed-aviary1.0
Points:
---
Bug Flags:
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040728 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040728 Firefox/0.9.1+

Something is wrong with the new search toolbar, because it does not work at all
on page where some ads are blocked (either by using userContent.css as detailed
here http://www.texturizer.net/firefox/adblock.html or by using an extension
like adblock).

Reproducible: Always
Steps to Reproduce:
1. Install adblock extension
(http://update.mozilla.org/extensions/moreinfo.php?id=10&vid=215&category=)
2. Go there http://forum.presence-pc.com/ and notice the ads on the top of the page
3. Try to search for a term on the page, like 'hardware', and notice that it
works perfectly
4. Block the ads on the top of the page (adblock iframe:
http://www.presence-pc.com/pub/*)
5. Try to search again the term 'hardware'

Actual Results:  
The search does not work anymore

Expected Results:  
The search should continue to work as intended

Before the addition of the search toolbar, FAYT or classic search had no problem
on pages with blocked ads.
BTW, adblock has two block modes: block and hide. Search continues to work with
the hiding mode.

Comment 1

15 years ago
Very interesting, I can confirm this using the userContent.css from
texturizer.net. I had been running into this problem ever since the toolbar was
checked in, although I never correlated it with pages that contained blocked
ads. This makes several high-profile sites, like Slashdot, incompatible with
FYAT for me.

Marking NEW, since I can't find a dupe.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

15 years ago
I have noticed this behavior too, so far I have only seen it with blocked
iframes. For example adding the following line to your userContent.css breaks
fayt on http://www.warp2search.net

iframe[src*="adtech"] {display: none !important;}

If you click the highlight button it correctly shows the matching phrases but
find next/previous still do not work.

Comment 3

15 years ago
Requesting blocking-aviary1.0 flag, since this breaks Find on high-profile sites
for people using the AdBlock extension or other ad-blocking techniques (which,
using on u.m.o's download statistics as a conservative estimate, is close to
200,000 users).
Flags: blocking-aviary1.0?

Comment 4

15 years ago
FAYT does NOT work for me when userContent css is applied to any site using the
uriid extension. Highlight does work, but FAYT doesn't. 

0730 moox build.
(Assignee)

Updated

15 years ago
Flags: blocking-aviary1.0? → blocking-aviary1.0+
Priority: -- → P3

Comment 5

15 years ago
I have also noticed this problem, its been driving me mad since this new find
thing was introduced, personally i cant stand the new method anyway.  Never
realised it was to do with my ad blocking css.  Agree this needs fixing asap as
its a rather huge problem not being able to search in a hell of a lot of pages.

Comment 6

15 years ago
Here is some more wierd fastfind behaviour that is due to ad-blocking.
BTW I have a userContent.css file which blocks ads.

1. Go to www.cnn.com
2. Type "/" to start fastfind
3. Start to type "inter" to find "international page" on www.cnn.com
4. After the letter e, the fastfind bar closes, and nothing is found
5. Try to reopen fastfind by typing "/".  Nothing happens
6. Try to open fastfind by using Ctrl-F.  The fastfind bar opens and we see
"inte/".  The / no longer initaites fastfind but is part of the search string.

Even shift-reloading the page stops "/" from initating the fastfind bar (even
though fastfind wouldn't work even if the bar did load up, such as with trying
Ctrl-F).  Loading another tab and going to www.cnn.com restarts the behaviour
from step number 1 above.

This behaviour can be quite annoying because there is NO way of searching for
something on the page other than using another browser or deleting my
userContent.css file and restarting.
(Assignee)

Comment 7

15 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Updated

15 years ago
Status: RESOLVED → VERIFIED
Keywords: fixed-aviary1.0
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.