FF want to access floppy when moving to old web page

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: david.balazic, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

FF brings up a "No floppy in drive" dialog, when trying to load a prevoius page
from history.

I first visited a certain ( intranet ) page, then another page on that site.
Then I dragged a text file form floppy ( window explorer ) into the FF window.
Then I dragged another one from the same floppy.
Then :
 - I removed the floppy
 - clicked BACK and it complained about missing floppy ( the above mentioned
dialog )
 - I clicked "Continue" in the dialog
 - I selected the intranet web page from the history ( clicked the down arrow
next to the BACK button )
 - it again complained about a missing floppy, I click again "Continue"

Now the URL bar has the intranet web page, so I click into it and press ENTER on
the keyboard. It again shows the floppy dialog !

Reproducible: Didn't try
Steps to Reproduce:

Comment 1

14 years ago
related/dupe of bug 142664?
(Reporter)

Comment 2

14 years ago
Maybe.

Note that I don't do _anything_ floppy related. Just enter ( well, it is already
entered ) an URL and press the "Enter" key. The URL is an intranet web page.
Nothing remotelly related to floppy.

Comment 3

14 years ago
(In reply to comment #2)
> The URL is an intranet web page.
> Nothing remotelly related to floppy.

Sure? Use for that page View Page Info -> Media or look directly at the source
code and look for file:///A links (images, css, embed).

(In reply to comment #1)
> related/dupe of bug 142664?
Not that bug, it's for DM. I guess similiar to bug 206962 comment 4 (that bug
and the others).
(Reporter)

Comment 4

14 years ago
Yes, the page is "floppy-free". I use it for weeks. I has absolutelly nothing to
do with any floppy. Otherwise, how could it load without an errors in a second try ?

Comment 5

14 years ago
(In reply to comment #4)
> Yes, the page is "floppy-free". I use it for weeks. I has absolutelly nothing to
> do with any floppy. Otherwise, how could it load without an errors in a second
try ?

I have found a similar bug when trying to download files from an FTP server,
when I select the default "save to disk" in the "Opening..." dialog, it should
save to the Desktop by default.  However even when this is the case it still
prompts me Many times to insert a disk in the floppy drive, i have to click
"continue" several times before it will allow me to save the file.  This is very
annoying as there is a warning sound that accompanies the dialog box every time.  

I have saved files directly to floppy in the past, but now even when I am saving
to the desktop it prompts me for the floppy.

Version information is the same.

Comment 6

14 years ago
(In reply to comment #5)
> I have saved files directly to floppy in the past, but now even when I am saving
> to the desktop it prompts me for the floppy.
That is the mentioned bug 142664. But it is different from this one.

(In reply to comment #2)
> Note that I don't do _anything_ floppy related. Just enter ( well, it is
> already entered ) an URL and press the "Enter" key.

Inherently it is floppy related, see your comment. I tested it with FF 1.0. I
did exact the steps you presented in comment 0 but I cannot reproduce it.

1) visit two web pages
2) dragged two files from floppy into the browser window
3) then removed the floppy
4) clicked BACK 
5) - and it complained about missing floppy (firefox.exe - no disk)
   - I clicked "Continue" in the dialog
6) An FF alert is shown "File xyz could not be located. Please check ...".
7) selected the last web page from the history (use the down arrow next to the
BACK button)

That works, no more dialogs/errors as expected.

In the JS console you see an error message.

Error: uncaught exception: [Exception... "Component returned failure code:
0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIWebNavigation.loadURI]"  nsresult:
"0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame ::
chrome://global/content/bindings/browser.xml :: loadURIWithFlags :: line 166" 
data: no]

I did the same with Mozilla 1.8a5 with browser.xul.error_pages.enabled = true.
It is similiar, except I don't get the dialog/alert, i.e. 5) is absent and 6) is
only the XUL error page "File not found" (as expected with the pref instead of
the alert). With Mozilla I get a similiar error in the JS console too.

Error: uncaught exception: [Exception... "Component returned failure code:
0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIDOMLocation.href]"  nsresult:
"0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame ::
chrome://global/content/netError.js :: retryThis :: line 30"  data: no]

For me is that the expected behavior except the No disk dialog in Firefox.
Please try it again with FF 1.0.

I would mark this as a dupe of bug 153377.
(Reporter)

Comment 7

14 years ago
Can not reproduce it with FF 1.0
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: History → Bookmarks & History
QA Contact: mozilla → bookmarks
You need to log in before you can comment on or make changes to this bug.